[SOLVED] AU and VST plug-ins not showing up on OSX 10.7 and 10.8


#1

I have updated to JUCE 5.2 and the project was set up with projucer. Also had to update the AAX library (deployment target 10.7).
I received a user report that the 64 bit versions do not load on OSX 10.8 anymore. I have tested it on my 10.7 system and the issue was the same.
The 32bit AU loads fine also on OSX 10.7 and 10.8. I build the plugins as universal binary with deployment target 10.7. The plugins work without any issues on newer OSX systems. All my plugins are affected.

I see following warning in the compile output. Not sure if this is relevant:

ld: warning: ignoring file /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.12.sdk/System/Library/Frameworks//AVKit.framework/AVKit.tbd, missing required architecture i386 in file /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.12.sdk/System/Library/Frameworks//AVKit.framework/AVKit.tbd

Does anyone know what the problem could be? Any help is welcome!

Edit: some additional info: The VST plugins 32 and 64 bit are both not detected on OSX 10.7, 10.8. The only one that seems to work is the 32 bit AU. The hosts show the 64 bit AUs but they fail when they try to load it.

Edit 2: the hosts say “image not found”


#2

The juce video module was the problem. Seems like this isn’t compatible to older OSX versions. I removed it and it works now.