Plugin Hosts fail to load VST, VST3, and AUs correctly (Xcode 7)


#1

Hello, 

I just updated to Xcode 7. Before the update I could build/run VST, VST3, and AU plugins in the Juce host and Reaper. Now when I scan for plugins, it tells me that they fail to load correctly. 

A common solution seems to be matching bit architectures. I don't think this is the case for me though because I couldn't load the plugins in reaper64 (not sure how to check if Juce plugin host is setup for 64 bit), and my xcode project architecture is set to Standard Architectures (64-bit intel).

When I updated Xcode, I replaced the CoreAudio folder in Extras since Xcode deleted it but now when I build my plugin, Xcode tells me that many values have been deprecated. 

Another strange test of note is that I opened the firstPlugin demo I made when I first started with Juce and had no problem building/running the program in a host (it was only setup for VST). However, when I tried to build it as VST3 and AU by adding the proper file paths, the same errors I am getting with my new plugins are popping up... Then I tried returning firstPlugin demo to its previous state and it still cannot be loaded just like the new plugins.

My apologies if this question has been answered before but I searched and couldn't find any topic similar to my case. I am a Juce noob though so maybe I've set something up wrong. Any help is greatly appreciated and if any clarity is needed, please tell me what to specify on.

Thanks in advance!

 


#2

By default Xcode 7 will build binaries that only run on OSX 10.11, which I don't think is released yet.. You might just need to change the compatibility version to 10.10 or earlier. (Obviously for an actual release you'll probably want to make it at least 10.7 compatible anyway)


#3

I have also gotten errors trying to run plugins built with xCode 7. When running in the debugger, I would get some debug output from Reaper saying that CoreImage.framework was not found. I got the same message from Pro Tools when trying to load the AAX version. I added the framework under "Build Phases->Targets->Link Binrary with Libraries" and set the status to "Optional". It loaded fine after that. Not sure if this is the same problem you are seeing but it might be worth looking at.


#4

I also had this problem. I just reverted back to Xcode 6.4.


#5

Works by following what @jules said.
After configuring OS X Deployment Target to 10.10, everything works fine.