Failing to compile proper VST files (OSX)


#1

Boring stuff first:

  • OSX 10.10
  • XCode 7.2.1
  • Juce 4.2.1 ( I believe, how would I double check?)

I’ve followed the basic tutorial. It compiles fine, however when I try to load the plugin in to the Plugin Host, it gives me this error message:
Note that the following files appeared to be plugin files, but failed to load correctly: FirstPlugin.vst

I tried compiling the GainPlugIn example project and it works fine.

Any ideas?


#2

The version should be spelled out in JUCE/ChangeList.txt, and the Projucer app also bears the same version number.

Did you re-save the tutorial project with the 4.2.1 Projucer? You should then end up with an Xcode project that has multiple targets, and build the VST one.


#3

Yep, it was 4.2.1.

The tutorial project was created with 4.2.1 Projucer, I’ve been building VST3, VST, and AU. All display similar errors (forgot to mention this in the original post)


#4

Only in the plugin host? Can you try logic, AULab or Reaper?


#5

I tried in Max MSP, it failed there as well. The fact that the GainPlugIn tells me something is wrong with my tutorial plugin.


#6

Hmmm. I’ve just followed the tutorial to the dot. And it works for me (and I’m on the same system as you).


#7

Hi, sounds like this might be similar to an issue I’m having where some files seem to be missing from the built pacakge:


#8

Changed the build setting to 10.10 (not upgraded yet) worked for me


#9

Changing the OSX Deployment Target from 10.11 to 10.10 seemed to do the trick. Its a bit odd. Maybe those types of settings should default to 10.7 or the users OSX version?


#10

I think that’s an XCode thing rather than Introjucer


#11

If you want to set this in the Projucer, you do so in your export target - OS X Deployment Target.


#12

Hi, I’m having the same issue running OSX 10.10 XCode 7.2 and Juce 4.2.4, but I can’t seem to find the setting to change the OS X Development Target in the export target settings… Am I just missing something obvious, or has something changed since 4.2.1?

I can change the XCode deployment target to 10.10 manually for the Plugin Host (otherwise it doesn’t run at all), but not sure how to do it for the plug in project.


#13


#14

Yep, that worked, thanks!