Moving from 3 to 4


#1

Hi, trying to move a VST project to Juce 4 from 3.2.

I backup up my 3 directory, installed 4 and then tried to build in XCode. Got some complaints about global_header not being found so I opened the project in Introjucer and resaved it.

This got past the global_header problem but there were lots of copy errors at the end of the build process and nothing ended up in the VST folder.

So I re-created the project from scratch in Introjucer and now everything build and ends up in the VST folder (woot!) but when trying to scan the VST host I get an error message saying that even though the files appear to be a plugin they failed to load correctly…

Not quite sure what this means - am I missing something else going from 3 to 4?

Cheers for any insight…


Failing to compile proper VST files (OSX)
#2

Don’t know what the problem with the plugin host is, but the copy errors using the old jucer file come from 4.2:
the post-build shell script in the introjucer/Projucer is superfluent now, in fact, it needs to be removed.


Instead you have the Binary location fields:


#3

Yes you need to compile and run the newest Projucer on your project. In fact, the Projucer should tell you about that post-build script and remove it automatically!

There is no more Introjucer in JUCE 4.2, so if you have an old Introjucer copy lying around and run that instead of the Projucer, it you won’t get a project compatible with JUCE 4.2.


#4

Thanks for the replies… Getting these errors when I try to load up, so looks like there’s something missing from the build…

Attempting to load VST: /Users/lee/Library/Audio/Plug-Ins/VST/MIDISynth-TB3.vst
2016-04-21 20:20:35.634 Plugin Host[27792:8252830] Error loading /Users/lee/Library/Audio/Plug-Ins/VST/MIDISynth-TB3.vst/Contents/MacOS/MIDISynth-TB3: dlopen(/Users/lee/Library/Audio/Plug-Ins/VST/MIDISynth-TB3.vst/Contents/MacOS/MIDISynth-TB3, 262): Library not loaded: /System/Library/Frameworks/CoreImage.framework/Versions/A/CoreImage
Referenced from: /Users/lee/Library/Audio/Plug-Ins/VST/MIDISynth-TB3.vst/Contents/MacOS/MIDISynth-TB3


#5

Changed the build setting to 10.10 (not upgraded yet) worked!