SOLVED: How to get Introjucer working in Linux?


#1

The key word in Jules’s response was ‘zenity’. I happily run a very, very lightweight window manager – which is to say, it’s not kde or gnome. Running kde programs outside of the kde gui works seamlessly, and of course there’s access to gtk. I’m seeing a gtk-type window when I run Introjucer. Hence kdialog is not relevant. However, zenity was not installed. So I installed zenity and its libgnomecanvas dependency, and all’s right with the world. Introjucer, etc. works just fine now.

That is, the hang-up was not something that has to be ‘debugged’, but instead the fact of depending on opening a dialog box with a script via zenity/kdialog. Not a bad choice, just not the one I (and my system) was expecting to see. First program ever on my box that required zenity; but now I have it, and problem solved.

UPDATE: Whoops, JuceDemo audio folder file selection still hangs. Introjucer does work.

ORIGINAL POST:
Yes, I am a complete noob in the Juce world, and sorry that this is a little bit of a delayed cross-post/bump from the Linux section (http://www.rawmaterialsoftware.com/viewtopic.php?f=5&t=11333), but what do I have to do to get Introjucer working in Linux? I get a program halt on ‘File/Open…’

That’s a pretty fundamental feature not working, which makes Introjucer completely unusable for me in Linux. And compilation on my Slackware 13.37 box produces zero errors after I told the Makefile to look for X11 in /usr/X11R6/lib64/, which is the standard on Slack64. (At first I also told the Makefile to look for lib64 generally – as I wrote in the previous post – but it didn’t make any difference in the compilation or the results, so I dropped that).

All that’s necessary to cause a program halt is to choose ‘File/Open…’ from the menu.
From the log:
JUCE Assertion failure in juce_File.cpp:149
Illegal absolute path: *** Leaked objects detected: 1 instance(s) of class FileChooser

By the way, the same thing happens in JuceDemo during Audio demo if trying to open a directory to find a soundfile. JuceDemo also compiles without errors, and everything else in it runs fine, except trying to choose a file.

I downloaded the pre-compiled Windows version onto an old XP box. It works without problems, and example programs compile and run fine in Visual Studio 2010, but that Introjucer claims to be version 3.0.0 (my compiled Linux version says it’s 3.1.0).

Obviously I’m interested in Juce because of the cross-platform possibilities, but it would be so much handier to work in my ‘normal’ Linux environment to get a Juce program up and running before compiling for other environments. (And I found that getting eclipse running was not very much trouble on my Linux box, either.)

So why is ‘File/Open…’ both in Introjucer and JuceDemo not working for me?

Anybody?


#2

It uses zenity or kdialog to run the dialog box… I don’t use linux much so haven’t checked whether that stuff works recently, but it could be something unusual about your set-up. Can’t debug it right now, but if you want to dig around, the place to look would be FileChooser::isPlatformDialogAvailable() and the code around there.


#3

What i ntoiced is that it works but it hides behind the main Introjucer window, have a look if that’s the case for you.