TableListBox Tutorial - non-editable fields


#1

Hey there

Sorry to post such a terribly n00bish question. I’m right at the beginning of my JUCE journey, still going through the tutorials. 16 lessons in I have hit my first wall.
https://docs.juce.com/master/tutorial_table_list_box.html

From the description and instructions I’m expecting the compiled result to allow text-editing of the table cells. I’ve yet to see this work though.

Has anyone else had this issue? Or am I somehow expecting the wrong thing?

Any thoughts or advice on this would be much appreciated.

Thanks in advance and best wishes,

Jeff
MacOS/Mojave/JUCE5.41/Xcode10.1


#2

you probably need to revisit your code for the tutorial section about custom components and setting the label to be editable.


#3

Thanks for the quick reply Matkatmusic.

Hmmm That’s exactly what I would have said. However, I’ve been over it multiple times now and am still getting the same result.

setEditable (false, true, false); line should make a label editable with double click and maintain uncommitted changes on a clickaway. It’s certainly worked that way elsewhere. It’s also already set as that in the tutorial .h file.

Has anyone here compiled this tutorial as downloaded, with no modifications, using Xcode10.1/macOS with JUCE 5.4.1?

Would love to hear if the compiled macOS executable works for you.

Many thanks!

Jeff


#4

In the tutorial code there is this line:

table.getHeader().setColumnVisible (8, false);

I’m not sure why it’s there, but column 8 is the editable column. If you remove that line then you’ll see it.

I’ll update the tutorial.


#5

OK, I’ve updated things but it’ll take 24 hours or so to refresh on the web.


#6

Hi Tom

Ah, I glanced at the line but should have commented it out as a test. Thanks very much for looking at this so quickly. The support is much appreciated, as are these superb tutorials!

Btw are you the Tom from here?

All the best,

Jeff


#7

Yep, unfortunately that’s me. I’ll get that removed too!


#8

Heh all good. I didn’t mind that actually. Was oddly comforting to know that I was following in an actual persons footsteps. :slight_smile: