TemporaryFile source code missing in iPhone target of JUCE


#1

the subject summarizes it up pretty well: I’ve got linking error when trying to build the JUCE demo for the iPhone, because some TemporaryFile symbols were not found.

Going into the JUCE project and enabling the .h and .cpp files for the TemporaryFile class in the iPhone target solved the problem.


#2

Yes, sorry - I always forget that xcode is hopeless at adding new files to all the targets. Thanks.


#3

some more things to polish: I’m using the amalgamated juce instead of linking against the static library, and at certain point the compilers complains about a double definition of the symbol quitMessageId.

It is right because the symbol is actually defined twice. I commented the second one and everything went smoothly, but I wanted to point this out so maybe you can change things and make this double definition disappear when using the amalgamated code


#4

How odd - I always have my warnings turned up to max, but never saw that one. Thanks, it’s just a typo and shouldn’t be there in the iphone file.


#5

…third thing: in the same conditions (build for the iPhone with Juce amalgamated), I get error because the Point class is ambiguous… simply adding the namespace specifier solves the issue (juce::slight_smile: and thus, since I know there are other classes where this is happening, I think you won’t have difficulties in solving this one as well


#6

I never managed to get the amalgamated build to work at all for iphone - there were internal compiler errors, presumably because of the size. Did you find a trick to get it going?


#7

I had no particular problems getting the amalgamated juce to compile and work for the iPhone… aside for those (solved) I mentioned before… what compile error do you get precisely?


#8

Haven’t tried it for a while - will have another go and see what happens.