Unable to get my AUv3 kAudioUnitType_MIDIprocessor showing up in Audiobus 3

Is this actually even possible?

I have been writing a midi sequencer VST for a while but I just recently tried to get the IOS Auv3 version working as well. I can get it working in AUM but not in Audiobus 3.

I already read all the threads I found regarding this issue and tried every possible combination of the following settings in Projucer.

Deployment target IOS 11.
Microphone Access enabled.
MIDI Effect Plugin. On.
Plugin MIDI Input.
Plugin MIDI Output.
Plugin is sandboxed.
kAudioUnitType_MIDIProcessor. On.

I tried with the AUv3SynthPlugin and it works well as a synth but it just disappears when I switch it to be a MIDIProcesor.

I would really appreciate some help on this even if is just to tell me is just not currently possible.

Thanks in advance.

Now I wonder if no answer means is just not possible yet or simply no interest in the subject.

The thing is that AUv3 is pretty much the only format that many IOS musicians only care about and midi processor effects seems to also be of growing interest in the iOS music community.

No one else is writing AUv3 midi processors with Juce that can be loaded in AB3?