Upgrade to Catalina, has the dust settled yet?

I just upgraded my iOS device to iOS 13 and now I can’t build for it without upgrading Xcode which requires me to update to 10.15 Catalina.

I hear for iOS dev there are no problems, but not clear on whether it’s still risky for desktop and plugin development. Anyone here on Catalina and doing ok?

I’ve been using Catalina for a few months now.
There are some extra pain points like not being able to run un-notarised software but that’s usually quite rare.

The main thing is if you’re stilling shipping 32-bit plugins. You can’t build these any more on Catalina.

2 Likes

@dave96 for example, is it possible to debug plug-ins easily in DAWs like, Reaper, Logic, Live or Pro Tools dev in Catalina ?

1 Like

It really depends on the DAW. They have to build with a load of extra entitlements to allow debugging which I doubt most do.

There was another thread around which discussed actually re-signing Live with your own entitlements file in order to be able to debug with it. So not exactly easy even if it is possible.

1 Like

Thanks guys. Looks like I’m gonna be holding off for a while longer, unless I get another Mac!

With this it works quite well, even with REAPER (see my comment there)

1 Like

Actually, an external hard disk is all you would need: I develop on macOS 10.14 normally but I have a USB disk with 10.15 that I can boot from for testing Catalina specifically

1 Like

There is a way to get around this by clicking at “Open Anyway” if you go to System Preferences > Security & Privacy.

However for some reason, when testing with Reaper, I can unblock un-notarised programs and AU plugins but I can’t unblock un-notarised VST plugins (I click “Open Anyway” but nothing happens). If anybody understands why this happens, please let me know!

As yfede said, you don’t need a new mac to test! (unless you are in need of a touch bar :wink: ). You can either use a separate partition, an external drive or even a virtual machine to run Catalina.

This was a temporary measure Apple had which has now been tightened up on I believe.
To open un-entitled apps/plugins now you need to turn off SIP.


This is a bit confusing though as hosts can use an entitlement to say they’ll load un-signed plugins. And depending on when the plugins were signed and shipped they might might be able to run without having the full entitlements and notarisation.

Interesting. Well, apparently under 10.5.4 (latest version so far), I’m still able to unlock without turning off SIP.

I would be very interested to know if Apple at some point accepts signed programs without subscribing to their 99$ Development Program. I would be a blessing to be able to sign for Windows and Mac with the same certificate, without all this extra subscription non-sense.

Signing and notarization are only required for downloaded software (which is why software you build runs). You can clear the downloaded flag on apps and plugins and then they should run. sudo xattr -r -d com.apple.quarantine /path/to/MyApp.app

I think you can get the gatekeeper option t allow software from anywhere with the sudo spctl --master-disable command and then re-enable in settings. https://www.phonetransfer.org/disable-gatekeeper.html

3 Likes

I was “forced” into it via purchase of a newer Macbook Pro. It has worked fine, tbh.

That entitlement issue occurs regardless of OS—I had to do it for Ableton on my Mojave machine.

I upgraded to Catalina so that I could test notarization of my plugins. It’s been very smooth actually.

Debugging in Reaper is fine - they have an unnotarized version that doesn’t interfere with debugging (which is pretty cool of them).

I’ve been using the script @danielrudrich linked above to debug in Live. But multiple times a day an OS dialog pops up saying that Live is “validating”, after which I have to run the script again. Not a biggie, and I’m guessing there is a way to stop macOS/Live from undoing my signature but I haven’t looked into it yet.

Not going to hold my breath, but yeah it’s quite uncool. I have no commercial plugins yet, so I’m paying Apple $99/year to distribute a free vst…

I swear I’m done with XCode. Autocomplete never worked, it just occasionally opens the popup with some random suggestions from time to time. It ends up taking GBs of cache, and the random backgrond process eating all the CPU and battery is just nuts. The cherry on the cake is that today, just compiling the same code with little changes, Xcode just decided that the linking phase would take way longer so now every time instead of 20-30 seconds to compile it takes 1 minute and a half or so. That plus all the people complaining XCode 11 taking more time to compile the same projects as XCode 10.

I was about to wait for Juce 6 to ease the transition to CMake + VSCode, but I think I’m gonna try to set it up already like others here did, at least Intellisense works flawless

I switched a while ago. Everything is mostly fine, but old 32 bit games don’t run which kinda sucks - good thing Boot Camp is still around. :slight_smile:

I got annoyed from running the debugging script on Ableton Live so I just disabled SIP - I know some people don’t like to do that though, but it worked just fine for me.

As for VSCode/CMake - I do have to warn you that even though I love VSCode and use it constantly, the intellisense using C++ is quite broken, and you get lots of false positives in the JUCE code.

I use CLion on Mac which works beautifully for that part - but it isn’t free.

2 Likes

That really simplifies development tasks and has a lot of benefits.

The down side is that your machine is now even less comparable to a user’s machine.
(same is also for Mojave with SIP turned off)

This is relevant when testing hardened runtime and other security measures.

That’s a good point. I do have another machine with it on, so personally I’m not worried, but this solution works for me.

Also, turning it back on is pretty easy.

Update for anyone that comes across this issue (specifically for iOS development): You need to add the relevant disk image(s) which can be found here

To make sure I’m aware of the context. This is relevant for people NOT using Catalina where Xcode 11.4 was NEVER available, making it impossible running ipa on newer devices with images available only for newer Xcode.

1 Like

Yes, correct, thanks for clarifying.