I think it needs a little bit of work. I think the existing class should be renamed to HttpUrl or something.
Anyways, it’d be nice to have the isProbablyAWebsiteURL function rewritten. For example: http://xjakel7/site/ would be a perfectly valid URL and is definitely a perfectly valid website url. I believe there is an rfc document or something that had the URL stuff down. probably rfc1738
NVM me…I just like to talk.