VST2 scaling factor crashes plugin

I tried to add a scale factor of 0.85 as default for my plugin, so when opening it in the DAW it will initially show the GUI scaled to 85% (setGlobalScaleFactor(0.85)). VST3 and AU are working fine, but VST2 crashes when trying to resize the window. Once the scale factor is set back to 1, VST2 has no problems anymore.

I tried it with an empty plugin as well and I got the same behaviour. (on Mac 10.15.7)

The debugger shows that it crashes in the VST2 Wrapper resizeHostWindow function.

1 Like

Is this happening in a specific DAW? I’m unable to reproduce this with the latest JUCE develop on macOS 10.15.7 with the JUCE plug-in host, Reaper, or Live. It’d be helpful if you could post the full stack trace as well as the code which produces the issue.

I am using Juce V6.0.7 and the problem shows up both in Reaper and Live.

Code stops at line 1240 in the VST2 wrapper:

sizeWasSuccessful = (host (wrapper.getAEffect(), Vst2::audioMasterSizeWindow, newWidth, newHeight, **nullptr** , 0) != 0);

I set the scale factor this way (I tried with a new plugin project and only added the scale factor and setResizable( true, true ):

float scaleFactor = 0.85;


There have been a number of VST scaling changes since then. Please try with the latest develop.