Vsttypes.h not found

#1

so i have seen this topic and know that after an update vst2 isnt supported. But i still get the very same error that the header files for vst arent found. I only have vst3 enabled in my projucer. In my global paths i have set the sdk location of vst3 to the SDK_VST3 from steinberg folder. But still it cant seem to find it.

Does anyone have any idea what the problem could be, or if there is some other location where i should set the path?

Thanks so much and apoligies for creating another topic for this problem, but i have tried everything in previous topics and none of it fixed it.

I have also tried updating and reinstalling.

#2

What exactly are you building? A GUI Application that can host plugins (like the AudioPluginHost application provided with JUCE), or an Audio Plug-in?

#3

an Audio Plugin

#4

Make sure that the “VST3 SDK Folder” of each exporter is empty, otherwise it will override the one specified in the Global Paths of Projucer.

And then it is advised to leave the “VST3 SDK” global path empty, so Projucer will use the copy of the VST3 SDK that is provided with JUCE.

1 Like
#5

thanks so much! i removed all the paths i had set manually and it worked :slight_smile:

Still strange because the paths i had set where to the copy of the SDK provided with juce…

1 Like
#6

Sometimes the different VST3 SDKs are not 100% compatible. By using the built in headers you avoid using an untested combination of JUCE version and VST3 SDK version.

The JUCE team keeps them up to date for you (sometimes with a few days delay).

1 Like
#7

If you’re using only VST3 trying explicitly removing the VST3 Folder from all places. that way JUCE uses its own tested and compliant VST3 SDK.