Pluginterfaces/vst/vsttypes.h not found

So as a forewarning I am a complete Newbie to JUCE and not super-proficient with C++ as of yet. I noticed that there have been a few other people on here who have had issues with the header filepaths not working correctly when accessing the pluginterface directory from the VST SDK folder, but I am not completely certain how to go about configuring the file paths so that they access the correct directory (which I would assume to be the directory in which I have stored the VST folder). How exactly do I go about doing this globally within the build settings?

Nevermind, I figured it out. The forum will not allow me to delete.

Hi, I’m a newbie too. What did you do to remedy this? Thanks

Hi @empdsp,
please refer to this thread:

For christ sake what did you do to fix this issue?

1 Like

You need the VST2 SDK, which Steinberg is not giving licenses for since October 2018, and actively taking down any repositories that contain it.

Thanks for the response. Is it just not possible to use the AudioPluginHost without it then?

You have a couple of options :

  1. Find the needed VST2 header files from somewhere. You can build VST2 plugins and hosts for your private use. Steinberg obviously can’t do anything about that.

  2. Disable the VST2 plugins support from the Audio Plugin Host project.

There should be a custom warning thrown if that header isn’t found tbh. Ran into this myself recently

Where would I be able to disable VST2 plugin support?

In the AudioPluginHost Projucer project settings :

Are you using a custom VST3 SDK? If so you should update to the latest version or, better yet, use the one that comes bundled with JUCE (by clearing any VST3 SDK paths in the Projucer).

The latest SDK (which JUCE contains) has pluginterfaces/vst/vsttypes.h in it already.

1 Like

I did not know you could access settings like that in the Projucer. However , it is set to disabled and it’s still giving me the error of not being able to find the vsttypes.h file. The problem must be something else.

EDIT: Nevermind i’ve got it working. Thanks for the help!

I was trying to use the built in ones. However , I did try using Steinbergs VST3 as an alternative after having no solutions worked and it just spouted errors as well.

I have looked over the forum and seen that before, to clear the path in global path’s option in the Projucer. It gave me the same error. However , I upgraded JUCE yesterday , and just tried it in the updated version. It has just been built successfully!

I’m having the same sort of issues here. I initially downloaded the SDK (which I just downloaded today) and linked to it via the Global Paths, but kept getting the error message that is referenced in this thread, so I followed your instructions to clear the global paths to allow the VST SDK that comes bundled with JUCE to be used, but now I’m getting this error message on my side. I also pulled all the newest changes as of a few hours ago and recompiled the Projucer as well, so I have the latest JUCE. Is there something I’m missing?


1 Like

You see the define switch around that include: JUCE_VST3_CAN_REPLACE_VST2

This is a switch, that should be switched off in the module juce_audio_plugin_client

The usual applies: save project from Projucer, make sure the IDE did refresh and rebuild

P.S. When you hit those defines, and don’t know where they come from, the full text search in your project is extremely handy

3 Likes

Thank very much, this fixed my issue. Much appreciated!