Extras/audio unit host missing in Grapefruit Juce?


#1

The basic audio plugin tutorial http://www.juce.com/doc/tutorial_create_projucer_basic_plugin says that there's a built-in plug-in host.

To access the host go to extras/audio plugin host/ and open the .jucer file with the Projucer.

I've seen this folder referenced on other forum threads too. Can someone help me find it? I must be being dumb.

Inside the downloaded juce-grapefruit-osx, there's an extras folder, but it contains the following, no audio plugin host:

  • amalgamation
  • binarybuilder
  • Introjucer
  • UnitTestRunner
  • windows dll

I see the same looking on the Github repo: https://github.com/julianstorer/JUCE/tree/master/extras

 

Can someone set me on the right path please?


#2

Sorry - I think it got moved from /extras into /examples

 


#3

Hi Jules,

 

Yup I now see it in examples... but it won't compile because it cannot find the VST SDK files.

For example:  Juce Modules > juce_audio_processors > format_types > juce_VSTPluginFormat.cpp fails on

#include "pluginterfaces/vst2.x/aeffectx.h"

because the path doesn't exist within the example. Instead it sits within the VST SDK and it doesn't know where to find it.

I tried manually putting in the correct path, which silenced this error but the next error comes up that Juce Modules > juce_audio_processors > format_types > juceVST3Headers.h fails on

#include <base/source/baseiids.cpp>

Again this is a path within the VST SDK.

 

NB: I have set up the global settings in Projucer to point to the VST libraries. I thought that would mean that projects would automatically find the right paths.

 

What can I do to get this example to work?


#4

It works fine if the path is correct. It just sounds like you've not set the path, or have set it to the wrong folder or something..


#5

Hi Jules,

Actually I think there's a bug in how the search paths get transferred to the XCode project. After a couple of hours searching, StackOverflow etc. I think I've found the problem.

 

Within Introjucer/Projucer global settings I have the VST paths set to

~/CodeLibraries/VST3 SDK

These appear black, which seems to confirm that it could find them and verify them.

 

When I click to open the project in the IDE (XCode) and I go to Build Settings > Search Paths > Header Search Paths they appear (in the first listed path) as

"~/SDKs/VST3 SDK"

and the User Header Search Paths are blank.

 

I've just manually changed the Header Search Paths so that that first item is my path

"~/CodeLibraries/VST3 SDK"

(with the quotes because of the space in the path) and finally I've got the project to compile.

 

Please could you verify.

Thanks.


#6

Just to add in on this

I am experiencing the same, no matter how I ammend the path ProJuicer never finds "aeffectx.h" and I get the same error from the XCode project


#7

Thanks for commenting. At least it's not just me going mad.

Here's my workaround:

  1. In XCode, select the project
  2. Select 'Build Settings'
  3. In case your Header Search Paths aren't showing up, select 'All'
  4. Locate the Search Paths section and within that 'Header Search Paths'
  5. Edit the VST path to your own one. If the path contains spaces, wrap it in double quotes.

See attached screenshot


#8

Thanks guys - we saw this and will investigate today..


#9

Hello!

I am unable to reproduce this; could you open source a project setup that reproduces the issue?


#10

OK whilst trying to produce the open source in XCode for you Joshua, I removed the "/" from the line 

#include "/pluginterfaces/vst2.x/aeffectx.h" in file juce_VSTPluginFormat.cpp

and the build compiled perfectly, however trying this in ProJuicer has not resolved the issue.  


#11

But our original code doesn't start with a slash (?) Did you hack that in accidentally or something?


#12

It must have sneeked in whilst It ried to resolve the issue. But in a dumb moment, I noticed I had not updated the SDK location within the Live build mode.  I'll take the groans and boos now.  However adding this did require me to change the angled brackets<> to quotations "" around the includes in the VST header juce_VST3headers.h, and this causes the JIT process to crash 

"Program used external function 'OBJC_CLASS_$_AUGenericView' could not be resolved"

I hope this isn't another dumb moment like above.


#13

Same issue here! I'm still fighting with VST3 path! Has anyone fixed?


#14

hi, paul im running into the same problem and tried your method without luck … would you be able to post a screen shot ? and or hint me in the right direction … thanks in advance !

what ive done so far …

  1. im on a mac, the JUCE folder with the Projucer application is in my Applications Folder
  2. Ive copied the VST SDK into the JUCE FOLDER … the hierarchy being JUCE/SDKs/VST3 SDK/ … and so on …
  3. i save and try to open the project in x code via the projucer
  4. in x code the aeffectx.h is missing
  5. the path in search paths the VST3 SDK is not showing
  6. attempts to paste in the path in the User Header Search Path wont change the missing header file alert !

#15

This issue still exists as of today?

I cloned JUCE, switched to develop branch, build Projucer, ran it, set vst3 SDK path in its global setting, opened example project “audio host example”, opened in IDE (tried with both Xcode and vsstudio 2015), tried to build the project:

Files not found

checking header/include paths, and these are set to default “~/SDKs/VST3 SDK” (Xcode), “C:\SDKs\VST3 SDK” (vsstudio 2015), no matter what I set in projucers global settings…

Am I doing something wrong?