Webbrowser component - paints only grey


#1

Hi,
i cannot get the webbrowser component working.

this is an example of my code:

WebBrowserComponent* browser;
addAndMakeVisible (browser = new WebBrowserComponent () );
browser->setBounds( 10,10,640,400 );
browser->goToURL( “http://www.raiseaudio.com/index.htm” );

it only paints grey … !?!

i tested it on XP and Vista.

what’s wrong ?

thanks in advance :slight_smile:


#2

I had created web browser component for my application, I used the link you where trying to hit and it opened it.

I would also like you to remind you that Am using juce_1.46 which was released and not the trunk version.

I have faced similar issue, you would have to check a thing, Check if the component holding the webBrowserComponent is visible when you call addAndMakeVisible(browser = new WebBrowserComponent () );.

It internally uses activexcomponent and try debugging it.


#3

Maybe the address string should be included in T()?

T(“http://www.raiseaudio.com/index.htm”)

to make it clear it is unicode text


#4

Yes, now it works !!!
The holding component has to set visible before creating the webbrowser.

thank you guys!


#5

Nice to that it works now. :smiley: