Weird file problem


#1

I’m having an odd situation here, where any call to File member functions causes an exception to pop up if the File is on a removable-media drive.

I’m trying to create objects to represent the drives in a file browser of sorts, using the findFileSystemRoots() function. For any drive where there’s no media inserted, if I try to use the File for anything (I’m just trying to get the volume label) then i get a popup error message:

[quote]Windows - No Disk

Exception Processing Message c0000013 Parameters 75b6bf9c 4 75b6bf9c 75b6bf9c[/quote]

… not even an exists() works. The program works but it pops up those errors whenever i examine the drives! I’m pretty sure it didn’t happen before.


#2

Bizarre.

But I just tried it on my empty cd-rom drive and it worked ok… ?? Any more clues?


#3

bumping this as evidence of similar problem to the recent post.

in my case it is with a USB multi-media [i.e. different types of SD etc] interface. it’s what my computer came with instead of a floppy drive [takes up one 3 1/2" drive bay, connected internally via usb].

I guess the problem relates to this kind of USB storage device - each of the slots show up as drives even if no cards are inserted.


#4