What I'm doing wrong?


#1

hi guys, when i open Logic with my midiplugin I got this errors:

JUCE v5.1.1
ca_require: GetElement(inScope, inElement) != NULL InvalidElement /Users/<user>/Applications/JUCE/modules/juce_audio_plugin_client/AU/CoreAudioUtilityClasses/AUBase.cpp:884
ca_require: GetElement(inScope, inElement) != NULL InvalidElement /Users/<user>/Applications/JUCE/modules/juce_audio_plugin_client/AU/CoreAudioUtilityClasses/AUBase.cpp:884

when i close it i got:

2017-09-14 19:04:54.899 Logic Pro X[54815:3405655] *** -[NSRecursiveLock dealloc]: lock (<NSRecursiveLock: 0x7fb6bd332bf0> '(null)') deallocated while still in use
2017-09-14 19:04:54.899 Logic Pro X[54815:3405655] *** Break on _NSLockError() to debug.

what is the problem here?
cheers!


#2

Both of these errors are not problematic. The first will go away in release mode - it’s an assertion in the CABase code by Apple. It’s nothing to worry about.

The second error is likely due to a bug in Logic internally but does not seem to have any implications.


#3

thanks!