XCode 3.1, Leo exported symbols


#1

When i created a new AU project in Xcode, fixed all dependencies and stuff. It builds, just one problem i get no exported symbols. This is because

ld: can't open -exported_symbols_list file: Juno.exp

is used, XCode forces one symbol in that file _JunoEntry (Juno is the name of the project), i’m guessing it’s generated by the AU template. I want a VST plugin i don’t care about AU. I can’t remove that option and from the manual, if the option is set only the symbols in the EXP file are included. This causes your script (witch uses nm -g) not to work and i’m guessing the plugin will not work either. Can someone tell me how to remove this option (i can’t find this in the project properties) or what symbols to add to the EXP file and how will this correspond to the JUCE_ObjCExtraSuffix option (is this suppose to be a string or a int).

Is it possible to have two build targets in one project, one for a VST plugin and one for a Standalone build, i got this to work in VS with no problem. It simplifies stuff.


#2

I’m pretty sure the how-to-build-a-plugin file tells you what to do about exports.


#3

i read it trust me, more then once.

i just don’t know how to disable this flag, i can’t find it anywhere, i tried comparing to the demo project, all options are the same. what am i missing.


#4

From the plugin docs:

[quote]- In the target settings, clear the “Exported Symbols File” setting. The exports are specified by directives
within the wrapper code, so don’t need to be listed explicitly.
[/quote]

That’s what you’re talking about, right?


#5

i have that cleared, i tried deleting thhe file (but thhat gives me an error). i can’ remove the switch thhat gets passed to Ld.


#6

I’m confused then - I’ve no idea why it’d behave differently from the demo. I guess you’ve been through the two projects comparing all their settings…


#7

I created a project and followed all the steps from the guide, and the problem occurs on the final build step. I managed to get my plugin working by editing the JuceDemoProject Xcode project (adding my own new targets and stuff). However a brand new AU project does not work (i double checked). The settings you talk about are clear yet the linker still has the flag set (see screens)

http://edo.im/data/proj_details.jpg
http://edo.im/data/build_errors.jpg


#8

These are the project settings - you’ve also checked the target settings, haven’t you?


#9

i didn’t, but i smacked myslef twice in the head, and removed that filename from the target properties, no luck, the option is still in LD command line, and LD still fails.


#10

Well, I’m out of ideas then! It must be something in those settings pages.


#11

i’ll make the best out of your demo project. i’m on leo ppc maybe i got the latest xcode version available for ppc. i’ll try to edit the project file and delete those settings by hand maybe it’s hardcoded in the template somewhere and can’t be edited out.


#12