Xcodebuild command line for projucer generated XCode projects


#1

Hope someone can help me. I try to build my projects from the OSX console, but result binaries are much bigger. Maybe they are compiled in debug mode or something. Thats my command:

xcodebuild -project ./tal-filter-2/Builds/MacOSX/Tal-Filter-2.xcodeproj -alltargets -configuration Release

Can someone help to find the right command? My OSX plugin projects are generated with the projucer and i want to build all targets in release mode.


#2

Mine looks just like that, except instead of -alltargets, I build the AU and VST separately.


#3

Thanks for the response. It seems that i also can’t add any build actions like “clean” at the end of the statement… i need to do alltargets because of my post build scripts.


#4

I’m still having issues here. Sorry i’m a windows guy :slight_smile: It seems to work correctly when i enter the command directly into the terminal, but it creates a different and huge binary when i execute it in a shell script that i start with “sh script.sh”… my script looks like follow:

#!/bin/bash xcodebuild -project ./tal-bassline-ci/Builds/MacOSX/tal-bassline-101.xcodeproj -alltargets -configuration Release

Can you explain why it runs different in the shell. I didn’t use sudo. Is there a way to execute a command just as it is… the same as you would enter it in the console like windows bat files?


#5

That seems crazy. There shouldn’t be no difference in executing a command in a bash script vs on the command line, just like Windows. Is it possible that you’re somehow pointing to a different project? Or looking at the wrong target final?


#6

I have used the same command. I also tried to use the build action “clean”. It works in the command line, but not in the shell script. I have really no idea what i can do to make this work. Also reinstalled the xcodebuild tools without success.


#7

Ok, i have found the problem. Never take a windows text file as base for a shell script. Maybe wrong line breaks or wrong encoding. Also do not use visual studio code for editing. It worked when i started to make the shell script with the oSX text editor.


#8

Whoa. Glad you found it.


#9

Thanks for your help :slight_smile: