You need to enable at least one plugin format


#1

I keep getting this error and I know it’s probably a basic question, but how do I do this?


#2

i assume you created a new Audio Plugin project with the IntroJucer/PrePaidJucer

If not then you are looking at massive amounts of pain.

If you are indeed using a freshly created project with it, then on the config page on IntroJucer, enable one plug-in format by marking the correspondent checkbox (vst2,vst3,au,whatever) – (You must have opened the .jucer file first then go to config)

Make sure you also set up the paths for the sdks correctly or it won’t build.


#3

We have a tutorial that explains in detail how to set all this up correctly:

https://www.juce.com/doc/tutorial_create_projucer_basic_plugin


#4

I am reviving this topic because of getting the same error, although all I want is to create just a Dynamic library and not a plugin at all !


#5

In order to help, we need to know a bit more about what you are doing exactly.

  • Which JUCE modules are you including in this Dynamic Library?
  • Are you changing the flags of some modules from (Use Default) to Enabled or Disabled? If yes, which ones?

Feel free to change the extension of the Projucer project from .jucer to .txt and upload it on the forum so we can have a thorough look.


#6

Ok, I get the point.
I’ ll do a deep check on every module and on every flag of all modules I have included in my project and i will make any obvious correction on it.
If the problem persists, I’ll inform you again.

PS. It may be just my false idea but I think the complexity of juce-modules tents to reach a critical level.