AAX - AAE Error 14018 - SOLVED (sort of)!


#1

When I load my plugin, I get an ‘AAE Error 14018’ arbitrarily.

It seems that the last function called in my AAX plugin is:

setPreferredChannelConfiguration(…)

Has anyone else had this issue before? Any insight would be helpful! I am going to continue trying to debug this in the meantime - if I find anything myself, I will post back here.

Any help will be greatly appreciated!


UPDATE - Solved!

I posted below how I fixed this problem - it did had to do with my setPreferredChannelConfiguration after all! The solution was basically removing it and sing the JucePlugin_PreferredChannelConfigurations instead.


#2

UPDATE:

Just found out if I reload PT after this error occurs, I get a different error and am asked to save a detailed report (which just reiterates AAE Error 14018):

“The following plug-ins were made inactive because of Insufficient system resources”

  • MyPlugin (DEBUG) (1)

#3

I solved the issue - sort of. I was using a 'setPreferredBusConfiguration() override to dictate whether my channel configurations were good, and am instead now using the Juce preprocessor:

JucePlugin_PreferredChannelConfiguration

After reading the documentation, I learned that you are supposed to use either one or the other, and not both (which is what I was doing).


#4

Yes, we are playing around with some API changes to the multibus system to make this less confusing (and removing the JucePlugin macro hell).