Adding mono-to-stereo hides mono-to-mono in ProTools?


#1

I’m trying allow mono-to-stereo in my AAX builds, but when I do, ProTools only shows the mono-to-stereo version. I just don’t get why it doesn’t show both as options. Is this a ProTools thing? A JUCE thing? Or just me? Here is my code from isBusesLayoutSupported():

if (layouts.getMainOutputChannelSet() == AudioChannelSet::mono())
{
	if (layouts.getMainInputChannelSet() == AudioChannelSet::mono())
		return true;
}
else if (layouts.getMainOutputChannelSet() == AudioChannelSet::stereo())
{
	if (wrapperType == wrapperType_AAX)
	{
    	if (layouts.getMainInputChannelSet() == AudioChannelSet::stereo())
			return true;
	}
	else
{
    	if ((layouts.getMainInputChannelSet() == AudioChannelSet::mono()) ||
  		layouts.getMainInputChannelSet() == AudioChannelSet::stereo())
			return true;
}
}

return false;


#2

Oops. Wrong code. That’s where I disabled the mono-stereo in AAX. Here is my code attempting to allow it:

if (layouts.getMainOutputChannelSet() == AudioChannelSet::mono())
{
	if (layouts.getMainInputChannelSet() == AudioChannelSet::mono())
		return true;
}
else if (layouts.getMainOutputChannelSet() == AudioChannelSet::stereo())
{
		if ((layouts.getMainInputChannelSet() == AudioChannelSet::mono()) ||
				layouts.getMainInputChannelSet() == AudioChannelSet::stereo())
			return true;
}
//
return false;

#4

Found the fix. I forgot about the AAX page tables. I had to add the mono-stereo as a new ID, and update getAAXPluginIDForMainBusConfig() to return that ID for mono-stereo.