After selection "Plugin is a synth" - for Logic it's incompatibille

after I set my plugin in Projucer to be a synth, now it’s incompatibille for plugin manager in Logic Pro X.

There is some info when I try to rescan it:
Bad Max Frames - Render should fail
/Applications/JUCE/modules/juce_audio_plugin_client/AU/CoreAudioUtilityClasses/AUBase.cpp:1447 inFramesToProcess=8192, mMaxFramesPerSlice=512; TooManyFrames
from AU (0x84e2031a): ‘aumu’ ‘wimp’ ‘woJt’, render err: -10874

ERROR: -4 IN CALL MusicDeviceMIDIEvent

But not sure what it does mean.

I guess you need to make it accept MIDI input, if you haven’t already. (Note that will probably also make the plugin not do anything unless it actually gets MIDI events…)

OK but how to accept it? Is there any method? Or what?
I found something like that:

bool WojtekImpulseAudioProcessor::acceptsMidi() const
   #if JucePlugin_WantsMidiInput
    return true;
    return false;

Shoul I change it ?

You need to enable it in the Projucer project properties. (Or maybe by manually editing AppConfig.h works too…)

What you are apparently trying to do (a signal generator that just outputs audio itself without incoming MIDI events etc) is a poorly supported use case in many hosts, plugin formats and JUCE.

OK I’ve just just select checkboxes in Projucer project settings:
Plugin Midi Input
Plugin Midi Output

I get the same error when try to rescan
But it doesn’t help

On my synth, under Plugin Characteristics, I have checked:

  • Plugin is a Synth
  • Plugin MIDI Input.

Under AU Main Type:

  • kAudioUnitType_MusicDevice

Hope that helps.

Hello, thanks for your support. Unfortunately it doesn’t help me.
Maybe my question was not clear. My aim is to built some kind of signal generator.
But I don’t want it to be instrument. I want it to be in Logic as regular effect that I can throw on insert slot. But I also want it to generate sound even if Logic playhead is stopped.
So what is the best settings in that case? I tried regular effect, but the sound was generated only if I Logic playhead playing. But when I hit stop, my generator also stopped generating sound. But I want generator to play all the time if it’s on insert slot, and of course if it’s not bypassed.
Somebody told me to make as you show - Plugin is a synth and Plugin Midi inputs. But then my plugin was an instrument in Logic. I don’t want that.