Android 4 r14


#1

My timing is terrible.

I just decide to try the Android stuff (from Introjucer) and this coincided with the new platform release.

I’m getting the aAnt error [quote]Error. You are using an obsolete build.xml
You need to delete it and regenerate it using
android update project[/quote]

I’ve tried ndk r6b and r5 but I can’t find how to get earlier versions of the SDK tools installed AND the 3.x platforms. (I managed to download r13 but the SDK Manager didn’t then list any available downloads.)

Has anyone else got this working with the latest release of the sdk/platforms?


#2

Managed to get a bit further by hacking various SDKs together (recipe for disaster?) specifically using the r14 stuff to download earlier SDKs then plonking the earlier (r13) version of the /tools into the r14 SDK folder.

Ice cream sandwich, more like http://www.youtube.com/watch?v=0LJoDCWvIRU#t=0m33s


#3

…one thing that needed fixing was that Eclipse wasn’t recognising the symbolic link in the project /src directory to the folder in the Juce source tree containing the two java files.

Not sure why that wouldn’t work on my system (unless it’s a broken version of Eclipse - I’m on classic 3.7.1).

Making a direct copy works but obviously that’s nor ideal.


#4

I need to update to the latest NDK - I’ll be on the case with this over the next few days…


#5

Thanks Jules.

I have something working now. For info, I’m using the r14 SDK but building using the r10 (2.3.3) platform and the r13 SDK /tools (the r14 /tools complains about the build.xml file). And I’m using the r5 NDK (as that seemed to be what was the defualt in Introjucer.)

The symbolic link is working, I probably forgot to do a refresh in Eclipse (although I was sure I tried that).

I want to get the build working on Windows too (don’t ask). Do I need one of Vinn’s hard hats for using Cygwin with Juce?


#6

Yes, or a think skull! I really don’t know whether it’s all in a state that would work with cygwin.


#7

Hi,

downloaded Android SDK r15 and NDK r6b and cannot make it build the JUCE Android example. The build.xml seems to be old…at least it tells me the file is “obsolete”. The structure of the build.xml files which I can generate with “android update project” look different to the ones which come with JUCE. Did you have any time yet to update JUCE to the newest SDK/NDK?

BTW: my first post…so greets from Germany :wink:


#8

Try the modules branch - I updated it recently to cope with the newer NDK changes.