Apps built using the latest JUCE (6.1.5) get rejected from app store!

I tried to submit a build using the latest version JUCE and I got this message back:

TMS-90338: Non-public API usage - The app references non-public selectors in PlugIns/MyPlugin.appex/MyPlugin: accessibilityColumnCount, accessibilityColumnRange, accessibilityDataTableCellElementForRow:column:, accessibilityRowCount, accessibilityRowRange,The app references non-public selectors in MyPlugin: accessibilityColumnCount, accessibilityColumnRange, accessibilityDataTableCellElementForRow:column:, accessibilityRowCount, accessibilityRowRange. If method names in your source code match the private Apple APIs listed above, altering your method names will help prevent this app from being flagged in future submissions. In addition, note that one or more of the above APIs may be located in a static library that was included with your app. If so, they must be removed. For further information, visit the Technical Support Information at

1 Like

Uh oh! I reverted to 6.1.4, and I’m still getting the error (even though I’ve submitted many versions of my app using 6.1.4). Not sure what to make of that. Maybe it’s Apple that has changed their filter?

1 Like

I’m seeing the same here thing this morning. My app was being accepted for TestFlight testing last week without issue, but fails now with the same error message. FWIW, I’ve been using 6.1.4 up till now…

1 Like

same here

Any clue how to build without the accessibility classes?

We also got rejected for the same reason. It seems to me though that the incriminated selectors are public and documented: Apple Developer Documentation


I was able to get my app accepted by commenting out these JUCE code lines:

Obviously, it’s only a temporary fix.


I’ve got a fix for this (pending our own internal code review). I expect this to be out later today or early tomorrow.


The fix is now on develop. It seemed to resolve the issue for me - once someone has confirmed that the fix also works for them, then I’ll cherry-pick the fix onto master too.


@reuk the fix worked for us :+1:

1 Like

Thanks, in that case I’ll push the fix to master.