AU plugin (generated with JUCE/Xcode) is not recognized by GarageBand


I created an AU plugin (generated with JUCE/Xcode) but it’s not recognized by Garage Band.

More informations about it:

  • sandbox option is on.
  • Auvaltool check is successful but auval -a gives the following result: **not open component: 4097

For information, I have no problem with this plugin under Adobe Audition.

Have you got a solution please ?

Some more information might help narrow down the problem.

Is this an AU or an AUv3?
Is this on an M1 machine or an x86_64 machine?
Does the plug-in work in the JUCE plug-in host? Any other DAW?
Have you tried debugging auval? How to debug (attach to) auval - need help - latest procedures?

I have the same problem, I was about to create a new topic, and will if it’s not the same context.
Brand new project from JUCE, even code signing added, AUv3 never shows up anywhere. Tried it on M1 or an old MacBook Pro.

Have you run the standalone version of the application? This seems to be required to register the plugin.

Then, in a Terminal (not iTerm, must be the built-in reset the plugin cache by running

killall -9 AudioComponentRegistrar

Alternatively, if you’re running the very latest Logic Pro you can go to the Plug-In Manager window and click the “full plugin reset” button.

Now, when you run auval -a from a Terminal, your AUv3 should show up in the list. You can then verify it with auval -v <plugin identifier codes> to see whether it can actually be loaded and used correctly.

1 Like

But if that’s the case, how do you get the plugin to your users? You tell them to also run the app first??

Yes, AUv3 plugins are normally distributed inside an app, e.g. through the App Store.

Oh, OK. auval has the plugin now. Just need to update all my packages now :smiley: