Audio host example not working with some of my plugins


#1

I am considering writing a replacement for the vst~ object in Max6 as the currently available version has problems preventing me from switching from Max5.

I thought I’d try using the guts of the audio host example as a starting point and then wrap the required MaxMSP SDK stuff around it to create the external.

I got the very latest version of Juce from git, built it with latest version of xcode 4 and tried it out.

The first plugin I tried to load was MTron Pro from GForce. Although it seemed to load, when I opened the plugin GUI, the controls on the GUI would not respond at all to my mouse or keyboard.

I then tried using Lounge Lizard (from AAS) and while its GUI plugin did respond to my mouse, after a minute or so, it just crashed.

Does anyone know if there’s a reasonably reliable audio host available with source code that I could use as a starting point?

Thanks,
D


#2

Have you double-checked that you’re using the latest version of those plugins? They’re both pretty old and may have needed bugfixes for more recent hosts…


#3

Yes, they are the very latest — I’m pretty rigorous about testing then deploying latest versions of all plugins I use as they have to work in several environments (MaxMSP, Logic, Digital Performer, Ableton). In fact I have a separate laptop specifically dedicated to this so that I make sure I don’t deploy a plugin to my live performance system that won’t work.

I should also add that my experiments are done on a laptop using 10.8.4 with latest official Xcode. However, I did leave the deploy target to 10.5 and I’m wondering if that makes a difference.


#4

You might just be unlucky in your choice of plugins - obviously the demo host is using the same engine as tracktion, so we’ve been working hard at getting plugins to be compatible, and have nailed most of them now. I vaguely remember hearing about problems with lounge lizard, I guess we should try that one. I can’t find a demo of MTron pro, though.


#5

I’m not familiar with tracktion. However, I have managed to get the audio host working with MTron Pro after bulding the audio host on a different machine (older version of xcode) and copying the app over. I’ll continue experimenting but this may be related to the use of pre-release stuff on my machine.

Can I expect any problems converting the audio host so that it lives in a shared library and started from somewhere else, as opposed to being a standalone app?


#6

Well, if you find out what it was, I’d be interested to know, as I can’t try MTron myself.

Don’t really understand what you mean, but the answer’s probably yes!