Audio latency on Windows 8.1


#1

I'm using the JUCE Plugin Host app. When I set the audio buffer size to anything less than 1024 samples (for DirectSound) I get pops when running the output test (the "Test" button in Audio Settings). If I use Windows Audio, I get an error saying input and output sample rates don't match.

I tried installing some ASIO driver ("ASIO4ALL"), but it didn't show up in the device list (though Ableton recognized it and it helped there, reducing the latency a bit, but still not to what I'm used to on OSX).

What should I do?

thanks!


#2

I'm into beta testing now and users are hitting this. I naively assumed that they would have better drivers than I do (I'm on a MacBook Pro... not really a proper Windows machine).

Any ideas?

thanks!


#3

If you’re not seeing ASIO, then make sure you check that JUCE_ASIO is enabled (see the options for the juce_audio_devices module in your Introjucer project). You’ll also need to make sure you include the path to the ASIO SDK in the header search paths for all of your Debug & Release targets.