AudioParameterTutorial seems broken-ish

gui
documentation
#1

I have 125% display scaling enabled on my laptop and the slider and checkbox of the audio parameter tutorial demo project go out of the frame of the plugin window. In the snapshot above I have compiled the “AudioParameterTutorial_04.h” file, but they all do this. I’m on Windows 10 using Reaper. I apologize if this isn’t the right place to put this!

0 Likes

#2

You can disable the display scaling for Reaper, I don’tknow of another way to fix this, sorry

0 Likes

#3

What setting do you have selected in the “Options->Preferences…->General->Advanced UI/system tweaks…->HiDPI mode (Windows 7+)” drop-down? It seems like the multimonitor aware support isn’t complete so I would recommend using either unware or aware.

0 Likes

#4

Unaware :frowning:

Neither option seems to fix it

0 Likes

#5

Per this comment you can go into the juce_gui_basics module in the Projucer and set JUCE_WIN_PER_MONITOR_DPI_AWARE to “Disabled”, and that will keep the plugin from trying to scale and cutting off the edges of the controls.

I’m just getting started with JUCE and just wanted to use the GenericAudioProcessorEditor class, so this works for me for now.

For what it’s worth, when I go to develop “real” plugins I’ll probably leave this disabled and implement a corner you can drag to make the GUI bigger, and try to save that scaling factor somewhere global. That’s what it seems other commercial plugins do at the moment.

0 Likes

#6

Are you using the latest version of JUCE and Reaper? I’m not seeing this issue using the JUCE develop branch with Reaper v5.973.

0 Likes

#7

I was using JUCE 5.4.3 and REAPER 5.96
I’ve had display scaling on Windows set at 125% since I logged in, that’s how I keep it on my laptop.
I also forgot to mention that I have “display scaling performed by application” selected in the Windows compatibility settings for REAPER because that used to make things look sharper on some old version of REAPER, and I appreciated the extra screen space when things were smaller.
¯\_(ツ)_/¯

0 Likes

#8

Looks like changing the high DPI settings back to default actually makes it work correctly. So so sorry I forgot to mention that. I keep it on for REAPER all the time on my laptop and forgot about it.

In my defense though, this doesn’t seem to break any other plugins and does give me a funny feeling about using JUCE’s high DPI scaling.

0 Likes