Max 8 Windows High DPI issue

In Max 8 with High DPI Rendering enabled JUCE plugins don’t display the GUI correctly. The GUI window scales to the correct size but the actual displayed part of the UI is of the unscaled size. Here it is with Windows set to 150% scale:

I’ve tested with an empty plugin template and JUCE 7. I also tested JUCE 6 quickly.

The plugin displays correctly if it is using setResizable(true, false); but I don’t want to make the GUI resizeable.

This seems to be related to similar issues in this old post but I didn’t see anything that I think is causing this issue:
High dpi issue on Windows with VST3 plugins - Audio Plugins - JUCE

Is this a bug in Max 8 or is there something I can do in the plugin to fix it that I’ve missed? Thanks!


I forgot to mentioned that. Yes, I’m using the default value as in the JUCE template. The plugin scales correctly in Reaper.

EDIT: Just in case, I tried explicitly setting JUCE_WIN_PER_MONITOR_DPI_AWARE to “Enabled” instead of “Default (Enabled)” in Projucer but no change, unfortunately.

The best way to determine this is to test out a non-JUCE-based plugin of the same format (VST2 or VST3) that supports hi-DPI displays. I think the FabFilter plug-ins probably fit that description, if you have any of those installed.

It would also be helpful to know whether you’re loading a VST2 or a VST3 plug-in, as scaling works differently between the two formats.

Thanks for the reply.

For info, I’m compiling VST3 plugin.

I’ve installed the demo of FabFilter Simplon VST3 and it seems to be scaling correctly in Max 8. When I load it in Max and Reaper both versions are the same size/scale. Let me know if there are any other tests I can run and I’ll happily do them.