[BUG] juce_audio_plugin_client_VST3.cpp setContentScaleFactor not work correct


I set the preprocessor define in projucer to JUCE_WIN_PER_MONITOR_DPI_AWARE=0 because juce sometimes scale components sometimes scales not. If a plugin report no scaling possible, the DAW can scale it all. studio one offer then a switch to enable scale of whole plugin. the juice plugin look blur but it is much better as some component scaled some not. with current code(develop tree from 24.5.23) this does not disable scaling correct . (i test the juce plugin example) see code in “JUCE-develop\modules\juce_audio_plugin_client\juce_audio_plugin_client_VST3.cpp”

#if ! JUCE_MAC
const auto scaleToApply = [&]

            // Cubase 10 only sends integer scale factors, so correct this for fractional scales
            if (detail::PluginUtilities::getHostType().type != PluginHostType::SteinbergCubase10)
                return factor;

            const auto hostWindowScale = (Steinberg::IPlugViewContentScaleSupport::ScaleFactor) getScaleFactorForWindow (static_cast<HWND> (systemWindow));

            if (hostWindowScale <= 0.0 || approximatelyEqual (factor, hostWindowScale))
                return factor;

            return hostWindowScale;
            //return factor;  // disabled old code
            return 1;    // the quick hackfix that disable juce scaling

        applyScaleFactor (scaleFactor.withHost (scaleToApply));

        return kResultTrue;
        return kResultFalse;

another problem i not find no fix for. the juce plugin compile with this define is still recognize from the DAW as dpi aware and studio one does not offer a switch to scale whole plugin. cubase does also not scale it. maybe other have a idea whats still wrong wy juce can not create plugins that are tell they are not highdpi ready ?

and some information wy a mac have no high dpi switch. reason is because mac retina monitor have over 200 PPI . a 21 inch mac monitor have 4k . a 32 inch mac monitor have 6k. with this high PPI can see not blur when window bitmap is scaled as in non hidpi mode . but on windows are 4k monitor with 32 inch very often used. i have it too. this give only 138 PPI and so see blur and hidpi mode help

if somebody want buy a new monitor with 32 inch i suggest use a 8k monitor or wait until they are cheaper. then can not see the blur and no hidpi mode is need. If it is lots work to fix juce that it work good in hidpi mode i did not know.

kontakt 6 is not hdpi able but it report correct and studio one offer the menupoint “enable Systenm DPI scaling” . so kontakt 6 work ok in DAW in high dpi mode except a little blur. what need do that juce plugins use no scaling and studio one allow switch it on i did not know.

here are screenshots of the juce plugin example with disabled scale. size look ok, but studio one offer no menu “enable System DPI scaling” . so

it still thinks juce plugin is able to correct scale