AudioUnit(s) built/compiled but not detected


#1

Hi,

A brand newbie here. :)
I've search here and across the net prior to writing...

So after the usual CoreAudio/Apple saga I've been able to get the JuceDemoPlugin to compile (with the latest GitHub master JUCE and compiled Introjucer).

Finally the moment of Build Succeeded arrived.
However, the Component (Audio Unit) isn't detected by no audio-host or AULab.

The VST2 however works just fine.

I've thought it might be CoreAudioUtilityClasses version so I've tried 1.1 from June 2014 and the one before it.

When trying to manually validate with auval I get the:

--------------------------------------------------
VALIDATING AUDIO UNIT: 'aumf' - 'Jcdm' - 'RawM'
--------------------------------------------------
ERROR: Cannot get Component's Name strings
ERROR: Error from retrieving Component Version: -50

		<p>* * FAIL<br />
		--------------------------------------------------<br />
		TESTING OPEN TIMES:<br />
		FATAL ERROR: didn't find the component</p>
		</td>
	</tr>
</tbody>

(I've also tried 'aufx' ofcourse)

Tried different target builds and Base SDK as 10.10 (Latest) or 10.9 (which is my system).

I'm using Xcode 6.1.1

Thank you!


#2

When people post this, it's almost always because you're building a 32 or 64-bit plugin and trying to load it in the opposite kind of host.


#3

Thank you for the quick reply but I’ve tested with 32bit and 64bit hosts and also changed through introjucer the build arch type between 64bit, 32bit and unibin prior to compiling.
Clean build of course and verified my settings are for release and debug.

Also tried changing the compiler and SDK and minimum sdk.


#4

Follow up,

On my case it seems the juce_AU_resources.r was missing in the Build Carbon Resources phase under Target.

I've tried loading the component with MainStage 3.1 which is fully 64bit "Cocoa" I guess. is Carbon still being used even for newer AUs?

(this might be a question due to lack of knowladege so my apologies).