Juce Demo Plugin - Can't load in host application


#1

Hello everyone!

I'm incredibly new to all this, literally two days old in terms of building audio units. (or learning how to anyway)...

Day one was interesting, spent hours looking for CoreAudio SDK to eventually find out it's now called CoreAudio Utility Classes!, Then spent another few hours trying to work out why I did not have the Audio Unit template in Xcode, to then find it does not exist anymore!!!! I attempted building my own template (file Structure) following a tutorial but it sadly wouldn't build and there were too many errors for me to begin caring about...

 

I'm using Xcode 5 and have the CoreAudio Utility Classes and VST SDK. 

                      - VST SDK is here, /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/include/VST_SDK

                      - CoreAudio is here, /Applications/Xcode.app/Contents/Developer/Extras/CoreAudio

 

After all this hassle and fuss I found JUCE! which has been amazing so far and I want to begin learning and using it properly. 

My main goal at the moment is to build the JUCE DEMO PLUGIN and get it working in the host application AU Lab, and even better would be LOGIC PRO 9. Then I plan on really indulging in the development side to things.

I've built the Introjucer, and finally built the JUCE DEMO PLUGIN    WOOHOO!  But!....

 

I copied my JuceDemoPlugin.component to here - /Users/georgeduller/Library/Audio/Plug-Ins/Components/JuceDemoPlugin.component 

 

This is all well and good and I began to think I'd finally done something... but I cant use it in either AU Lab or Logic Pro 9.

I've tried 32/64 bit and 64 bit and have had no luck, also restarted my macbook pro, still no luck. 

 

I'm sure there is somethingIi'm doing wrong or have missed but as I'm so new to this I'm not sure what it is.

Any help would be musch appreciated, I've found similar posts relating to the topic but have yet to find the answer...

 

Cheers,

George!

 

 

 

 


#2

SOLVED!

At first I realised I had saved the component file to my user directory and not my HD - my Macintosh HD was hidden.

After moving the .component to the HD it still didn't load in Logic or AU Lab...

 

Turns out I had to edit some things in the introducer...

OSX Base SDK Verision - 10.9

OSX Compatibility Version - 10.9

C++ Library - Use LLVM Libc++

 

And now it works YAY!

 

Now i need to learn how to make my own...... wish me luck!! hehe

 

George


#3

I think I'm having the same problem:

 

http://www.juce.com/forum/topic/au/component-problem

 

I'm just looking for these settings that were edited in the introjucer, where abouts are they?

 

Thanks


#4

If you load the JuceDemoPlugin.jucer in the introjucer, click on Debug, underneath Xcode (macOSX)...

 

Attched is a screen shot,

 

Hope it works!

 

 


#5

Hi mate, thanks a lot for the reply - Unfortunately no joy for me yet though with changing those settings!

 

Edit:  changing the OSX Architecture to "Universal Binary (32/64-bit) has worked :D


#6

You have totally solved the same problem for me. thanks a lot!