Audio Unit recognition--or lack thereof

I am having a problem with an audio unit plugin that no longer is recognized as such. I had a working audio unit plugin that I modified by adding some code. I did not change anything that should effect the component structure such as juce_AudioUnitWrapper.r, my JucePluginCharacteristics.h, or my .exp file, yet, now, after I build my component and copy it to /Library/Audio/Plug-Ins/Components/ and run auval -a, my audio unit no longer shows up in the list.

Does anybody know how I can tell where the Component Manager is failing to recognize my plugin?

This reference page indicates four requirements for recognition.

[list]Be packaged as a component, as defined by the Component Manager[/list][list]Have a single entry point that the Component Manager recognizes[/list][list]Have a resource (.rsrc) file that specifies a system wide unique identifier and version string[/list][list]Respond to Component Manager calls[/list]

How do I verify that any of these are correct?

Has anyone else had a similar problem? Or do I have to write my own test harness so I can watch the Component Manager do its thing?

I’ve sometimes had this happen, but never figured out why. Deleting the plugin and rebuilding completely usually seems to kick it into life.

I have the same problem with JuceDemoAU : the project builds fine, but Logic and Live fail to detect it. Tried auval -a and it doesn’t show either.

I’m using the latest Juce source code from subversion repository (got same results with latest official release 1.45), and my config is a PPC Mac with OS X 10.4.11 / Xcode 2.5

I built (and rebuilt) the project as a UB in both debug and release modes with no luck. Enabling “force package info generation” flag as Jules suggested me didn’t help either.

According to this thread, shouldn’t there be resource (.rsrc) file in the JuceDemoAU project? I don’t see any.

I’m a bit stuck… Any idea?

As already posted in another thread

It’s a known issue with the coreAudio SDK of xcode 2.5


I had missed that one in searching the forum.

It now works, merci beaucoup!

I think I should do this too

I don’t know which part modify …