OSX doesn't recognize a plugin

Hello. This is my first posting. I’m a long-time embedded DSP developer, but have only been working with Xcode and Juce for a little while. I’ve been able to resolve most of my issues by reading posts here, digging around the HTML document and bashing through debugging. But I’m a little bit stumped right now.

I’ve been able to build a first plugin by gradually modifying the Juce demo AU. I’ve been able to rename things so that my plugin has the right name, so I have a reasonable understanding of that part. I test with both the Juce Plugin Host and with Logic 8. This first plugin is stereo-in stereo out. It passes all the scans and sounds the way I expect.

I wanted to build a mono version of this same plugin. I did what I needed to do code-wise, and modified the project settings and the various configuration files. The plugin builds without complaint and the component bundle looks fine. I opened up the bundle and the files inside look like the stereo version, with the exception of things that are renamed. But the plugin doesn’t pass AU validation. It doesn’t even appear to be seen by the applications. I receive an error from “OpenAComponent”, with a result code of -50. Of course this result code isn’t even listed in the Xcode documentation. The best I can guess is that the actual AU file isn’t seen for some reason.

Does this ring any bells for anyone? I’m working with Juce Version 1.46 and Xcode 3.1.2. Thanks much!

check that the resource file is built in this plugin version too.


I’ve also spent days staring at problems like this. It does usually come down to the resources being subtley wrong. There’s a “force info generation” (or something) flag in the project settings that seems to be important.

Think I found something. There was a bad character in the definition of ‘JucePlugin_AUExportPrefixQuoted’ in the plugin characteristics file. Most of the other stuff in that file will cause link or other errors, but not this one. I’ll keep my fingers crossed, but I appear to be unstuck now.

Thanks for the suggestions!