Automating parameter in Cubase 5 Windows- setparameter() not being called?


#1

Hi,

I'm trying the JUCE demo plugin and in Cubase 5 Windows 7, automation of parameter is not played with the demo plugin...

It's confusing because on Cubase 5 OSX it works normally but not in windows :  setparameter is not called at all in the debugger... 

I tried JUCE 3.2 and JUCE 4.10. Cubase own plugins are automated but not JUCE plugins... How could it be that nobody spoted that ?

The same JUCE Demo plugin file can works on Reaper though. 

Any idea ?

Salvator

 


#2

Hi Salvator,

just did a quick test here: fresh Git pull of Juce master + Cubase 5.5.3 (32-bit) + Windows 7 Ultimate 64-bit (all latest updates) + debug build of Juce audio plugin demo.

Gain knob automation is being recorded (red W button on plugin activated), and when being played back (green R button activated), the gain knob also changes according to the registered automation events. Breakpoints in AudioParameterFloat's operator= and setValue are also being hit.

(the only thing is that continuous chnages to the gain knob end up as discrete changes, but that's probably because the start/end gesture calls are used to coalesce the continuous changes)

Koen


#3

Hi Koen ! Glad to hear from you ! :-)

Thanks for the feedback.

I used the grapefruit for windows, but will tried again, on a fresh computer with the latest Juce pull from Git.

Thanks again,

Salvator

 


#4

UPDATE : finally Koen has the same problem than me in Cubase 5. Works in Cubase 7, not in 5.

 

For me when I use the same demo plugin in Cubase 8, it works fine, but in Cubase 5, it don't read the automation at all...

 

Any Roli advice ?


#5

Not sure what to advise.. Could it just be a Cubase bug that they fixed since V5?


#6

Actually, just to make sure I wasn't entirely going crazy, I did a few more tests and could consistently reproduce the following behavior:

1. build the 32-bit version of the Juce audio plugin demo + run in Cubase 5.5.3.651 32-bit

--> automation is written, but NOT read

2. change the build settings in Introjucer to 64-bit and build the 64-bit version of the Juce audio plugin demo + run in Cubase 5.5.3.651 64-bit

--> automation is written, AND read as well

I could reproduce the same behavior with the beta plugin you sent me Salvator: reading back automation doesn't work in 32-bit, but does work in 64-bit version.

So, it appears there is something wrong with the combination Juce-based plugins and Cubase 5 for the 32-bit version, but not for the 64-bit version.

Two more things:

- automation writing and reading does work fine with Steinberg's plugins in both Cubase 5 32-bit and 64-bit (no idea if these are special or anything)

- this is NOT due to any recent changes in Juce, as an old build of a Juce-based plugin from July 2013 exhibits the same behavior

PS: all of this tested on Win7 64-bit latest updates, with freshly pulled Juce repo


#7

I tried reproducing this in Cubase 7.5 but it seems to work for both 32-bit and 64-bit there. Seems to be a bug in Cubase 5.