Bleeding Edge downloaded today gives 3 errors


#1

Hi,

I just updated my project to the latest bleeding edge Juce. Now I get 3 errors:

Undefined symbols for architecture i386:
“createPluginFilterOfType(juce::AudioProcessor::WrapperType)”, referenced from:
JuceAU::JuceAU(ComponentInstanceRecord*) in juce_AU_Wrapper.o
(anonymous namespace)::pluginEntryPoint(int ()(AEffect, int, int, int, void*, float)) in juce_VST_Wrapper-29A534B76FCBBCE1.o
"AUBaseLookup::Lookup(short)", referenced from:
APFactory<AUBaseLookup, JuceAU>::Factory(AudioComponentDescription const*) in juce_AU_Wrapper.o
ld: symbol(s) not found for architecture i386
clang: error: linker command failed with exit code 1 (use -v to see invocation)

OS X: 10.7.5
Xcode: 4.5.2

Any help would be great. Thanks,

K :cry:


#2

It now needs a couple more Apple cpp files. Re-save your project with the introjucer and it should sort it out for you.


#3

Thanks Jules,

I’ll give that a try.

K


#4

Any chance you might just mention what the files are? I’ve got a complex project I’m not about to put through the Introjucer.


#5

AUBaseLookup.cpp, I think? Have a look at the git diffs and it should be easy to spot.


#6

Found this on the Apple Developer site. Seems to satisfy the link. Don’t know if it runs yet.
[color=#0000FF]AUPlugInDispatch.cpp[/color]


#7

I had no trouble with this on XCode 4.x. XCode 3.2.6 is another thing entirely. Any hints?


#8

In Xcode 3.2.6, in Juce_AU_Wrapper.mm at this line:
[color=#0000FF]JUCE_FACTORY_ENTRY (JuceAU, JucePlugin_AUExportPrefix)[/color]

I get this error

[color=#0000FF]‘AUBaseFactory’ was not declared in this scope[/color]

I know 3.2.6 is old, but I’ve got a handful of products that still depend on it.


#9

I guess it’ll need some kind of macro to allow you to disable that factory stuff for xcode 3… Something like this?

#if ! JUCE_DISABLE_AU_FACTORY_ENTRY JUCE_FACTORY_ENTRY (JuceAU, JucePlugin_AUExportPrefix) #endif


#10

[quote=“jules”]I guess it’ll need some kind of macro to allow you to disable that factory stuff for xcode 3… Something like this?

#if ! JUCE_DISABLE_AU_FACTORY_ENTRY JUCE_FACTORY_ENTRY (JuceAU, JucePlugin_AUExportPrefix) #endif [/quote]
I’ll try it out here and see what happens. Let you know. Thanks.


#11

I updated to the latest tip and run into the same issue with XCode 4. Adding the juce library file juce_PluginUtilities.cpp resolved the linker error.


#12

The introjucer adds that file automatically - if it was missing, you may have deleted it by mistake?