2.0.38 Parse Issue (JUCE_AUTORELEASEPOOL)


#1

I’ve just updated from 2.0.32 to 2.0.38 and I’m running XCode 4.6.1

My plugin compiles fine in .32 but I get 3 Parse Issues with .38 in juce_AU_wrapper.mm - all the errors say: Expected ‘{’

Base SDK is set to 10.7, I’m on 10.8.3

The first error is at line 262, the second line 1208 and the third line 1324

All immediately follow use of JUCE_AUTORELEASEPOOL

Reverting to the .32 modules compiles fine.

BTW - Tried creating a new Plugin project with Introjucer and I get the same errors.

The problem is with the JUCE_AUTORELEASEPOOL macro - if I comment it out the error disappears and I get a similar issue next time it’s used.

Thanks,

Rail


#2

Damn… Sorry, I changed the syntax for that macro, but it looks like when I searched the source-tree for it and updated all the uses, I must have missed out a bunch of files. Have fixed it now, try again!


#3

Hi Julian,

I still have the same kind of errors in juce_VST_Wrapper.mm (and not in the AU wrapper).

Thanks.

Thomas


#4

Yeah, I did another update to fix that a while ago.


#5

[quote=“Inr”]Hi Julian,

I still have the same kind of errors in juce_VST_Wrapper.mm (and not in the AU wrapper).

Thanks.

Thomas[/quote]

I get this with the latest tip too…

juce_VST_Wrapper.mm lines 181 and 227

Thanks,

Rail


#6

BTW - After putting in the braces myself and attempting to compile the Introjucer created (test) project I’m getting a bunch of linker errors related to “duplicate symbols” and AU .o files. (All other formats: VST, RTAS, AAX 64 bit compile fine)

Thanks,

Rail


#7

Goddammit, I missed another instance of it… Ok, the plugin demo definitely builds now!


#8

Yes - the demo plugin builds fine…

IntroJucer created plugins however need some help…

a) You need to add the method

to the AudioProcessor derived class.

b) Using XCode 4.6.1 I’m getting link errors when building an AU plugin

Cheers,

Rail


#9

No, that method is definitely defined. You mustn’t have the latest version of the introjucer.


#10

Hey Jules
Just updated to the latest Juce tip and when trying to build the Introjucer I’m still getting many ‘Parse Issue: Unexpected ‘@’ in program errors’ within the following files:

  • juce_posix_SharedCode.h
  • juce_mac_Files.mm
  • juce_mac_Network.mm
  • juce_mac_SystemStats.mm

I’m running Xcode 4.0.2 on OS X Snow Leopard. I last updated to the latest tip on the 22nd and wasn’t getting this issue then.


#11

Wish I’d never bothered changing this. Which compiler are you using?


#12

LLVM GCC 4.2


#13

Well, I made sure it works for that compiler. Are you sure you’ve got the latest version?


#14

Hmm, interestingly when tested on Xcode 3 or Xcode 4.6 on Mountain Lion everything is fine.

Is there any scope is this problem being as a result of a bug in the version of Xcode I have?
Unfortunately it isn’t possible to upgrade to any later than 4.0.2 on Snow Leopard.


#15

Yes, could be a compiler bug. If you need to work around it, grab the latest version and build with JUCE_COMPILER_SUPPORTS_ARC = 0


#16

Thanks Jules, compiles fine now.


#17

I deleted my juce folder and had downloaded the latest tip, rebuilt the IntroJucer as a Release build, created a new plugin project… But will retest to make 100% sure it’s the latest…

Rail


#18

https://github.com/julianstorer/JUCE/blob/master/extras/Introjucer/Source/BinaryData/jucer_AudioPluginFilterTemplate.h


#19

https://github.com/julianstorer/JUCE/blob/master/extras/Introjucer/Source/BinaryData/jucer_AudioPluginFilterTemplate.h[/quote]

Okay - “Show in Finder” was pointing to an older build (even after a Clean/Build)… until I manually deleted that build and rebuilt the tip… Now “Show in Finder” doesn’t become available, but I can manually find the output app and it works…

Weird!!

Thanks!!

Rail