Breakpoints in plugins in Xcode


#1

I’m working with Xcode 8.2.1 and working on a plugin that I debug with the plugin host. This always worked fine, I’m not sure when it broke, but my breakpoints in my plugin code are no longer hit. Any ideas what could cause this? Usually when this happens it’s because I’ve switched to the release build and forgot to switch back. Anything else that could cause it?


#2

Usually caused when your source doesn’t match up with what you’re actually debugging. Maybe clear out the plugin from the host and rescan it. Check the date on the plugin to make sure it’s being created/copied to destination correctly.


#3

if you work with others, sometimes the optimization flags within the release flag get turned off of no optimization, potentially causing weird behavior. Double check the optimization levels in the debug build in your shared code


#4

Breakpoints seem to work in the AU, but not the VST. I can work in the AU for now…


#5

Sometimes just re-lauching xcode after trashing /Users/YourUserName/Library/Developer/Xcode/DerivedData worked for me in the past.
Otherwise @jimc did a list of the most common reasons here :


#6

I’ve practically given up on Xcode it’s been so unreliable for me! Seems to particularly affect JUCE projects :confused: