Bugs in M1 Logic Pro Itself

If any other MIDI FX devs out there have had issues with the M1 version of Logic Pro, I just wanted to share for your sanity that it’s probably not you, it’s Apple. I’ve hit some very strange MIDI FX bugs that appear to originate from the M1 version of Logic Pro itself, not from the plugin code or JUCE. The plugin in question is a free MIDI effect called Ripchord and the open source code can be viewed here: GitHub - trackbout/ripchord The latest released version of the plugin was built with JUCE 6.0.8, but I am currently testing with JUCE 6.1.5 and that is the version of JUCE I used to demonstrate the bug described below.

The most egregious bug is that when you load an instrument on a MIDI track in M1 Logic Pro, and then load Ripchord as a MIDI FX on the same track, it changes the pitch of the notes, sometimes it pitches them up, sometimes it pitches them down, sometimes it doesn’t happen at all. It is totally bizarre and unpredictable, and again, Ripchord works perfectly as expected in every other major DAW, on every other OS, even Logic Pro on an Intel Mac.

I made a screen recording of the bug where all I do is load an instance of Ripchord, which in its default state does not transform the MIDI notes at all, it just passes them through, and then I play the same three MIDI notes over and over, middle C, D, and E, but you can hear that when Ripchord is first loaded, the notes get pitched up, and then when it is powered off and on again, the notes get pitched down. Here is the screen recording: Dropbox - Logic Bug.mp4 - Simplify your life

I understand that numerous M1 Logic Pro specific bugs have already been reported to Apple, with little movement on Apple’s side thus far. I’ve also heard there is an Apple engineer floating around these forums so perhaps they could chime in!

1 Like

Apple knows about the MIDI problems. Looks like some basic things are broken on M1 that arent easy to fix. See last post here:

1 Like

Ok cool, at least they appear to have diagnosed it if not fixed it. Thanks for the heads up!

This all seems to be fixed in Logic Pro 10.7.4. Can confirm the fixes advertised in the release notes work on our end. :raised_hands:


Unfortunately we are still seeing some odd behaviour and crashes with our MIDI effect plugin on Logic 10.7.4

That is unfortunate. Maybe @mfritze would be able to confirm whether the known issues in the Smart Splitpoint processing code that he mentioned are still outstanding, or if it might be something else…

Please file a bug via the ProAudio Seed program – or, if that is not possible, file feedback via Logic Pro. Mention my name…


adding a +1 here.

Running Logic in Rosetta mode is the only workaround I’ve found so far. Not something you want to recommend to a user who’s excited about his freshly bought M1 Mac :wink: But it implies that it is somehow related to M1. Unfortunately, just running the plugin under Rosetta has not worked around it.

In addition to the described problems, random midi notes are generated when activating / deactivating my MIDI plugin in M1 Logic.

Also interesting: If in CMakeLists.txt the midi inputs and outputs are disabled, the error disappears, but midi events are still processed by the plugin…



1 Like

Please check your Audio Units with the latest Logic Pro Seed, which we have released on https://appleseed.apple.com.

@mfritze How do we get an invite to the Logic Pro Seed? I tried to sign up but it seems to be for testing a beta of macOS rather than Logic.

1 Like

To join the ProAudio Seed program at Apple, you can simply send me (Markus Fritze mfritze@apple.com) an email with your name, company, your (main) Audio Unit(s). Most important: I need the email matching the one used for the AppleID on your developer account, because you need an active developer account to be part of the seed program. Within a week you should send receive an invite. If not, then there is probably a spam filter on your side filtering our the invite – we had cases where this was simply not solvable, because all invites were eating by some spam filter.

That’s it,