Midi fx plugin will not run under Logic on M1


we’ve been having problems with some AUs on M1 as discussed here

Today I decided to start from scratch to see if I could figure out the issue.

I created a new plugin project, set the type to be:

and tried to load it into Logic.

Immediately got the dreaded:


So it looks like midi fx plugins generated by Projucer need looking at.


You might have seen this thread:

It’s being worked on.

ah, thanks. hadn’t seen that.
though doesn’t really describe my issue - no crashing, just that horrible dialog.
guess it could all be bundled up in the same problems.

I rather think, since @reuk started to fix things you are seing different symptoms. You could go back to 3 days ago and see, you might see just the spinner then, but that is now guessing.

It seems you are doing pretty much the same everybody in the other thread did.

But we will see. Let’s wait and drink tea, as the proverb goes. Strangely that phrase doesn’t exist in England, it would fit so well :wink:

Welcome to the world of sandbox. It might’ve crashed and you can look on the AUHostingServiceXPC crashlogs.

Update: just saw you’ve eventually hooked to debug the thread and saw it actually didn’t crash.