Build errors on Xcode (repro-ed in IntroJucer)


#1

“CoreFoundation.h” file not found. This is a fresh install of Mac OS X, fresh install of Xcode, fresh clone of the JUCE repository, nothing else:

[attachment=0]Screen Shot 2012-04-30 at 10.10.31 AM.png[/attachment]


#2

CoreFoundation is one of the absolute basics, the only ways I can think you’d fail to find it would be if you had no system include paths, or if you hadn’t installed an SDK at all… Either way, you’d be unable to compile anything at all!


#3

Yes, that’s exactly the case!!! WTF? Do I uninstall Xcode and reinstall? Was I supposed to download some SDK also?


#4

No idea! When I installed it, everything just worked… I’m pretty sure the SDK is part of the download, not something you get separately.


#5

I very recently (about a month or so) did a completely clean install of Lion & Xcode. I can confirm that it should just work. The only thing I can think of is that for some reason the Cocoa libs aren’t being included in the system search path.

Have you tried installing the Command Line Tools (Xcode -> Preferences -> Downloads)? This might add some includes to your paths. Does a new Cocoa based project (that doesn’t rely on juce) compile?

I did know someone who had a similar problem with stdio not being found with an Xcode download. Perhaps try just re-installing Xcode if the above doesn’t work.


#6

Had the same problem. Then I realized I needed to wait for my freshly installed copy of XCode 4.3 to finish downloading all of its components. Click on the iTunes-like status bar at the top and you will get a drop-down full of progress meters showing any currently running background downloads.

Once the downloads were finished, the new Introjucer compiled without incident.


#7

I had a problem yesterday, if you download Xcode, the is the Xcode.app thinggy, you drag it to apps click it, it does some magic and it’s read to go (you might thing). I wen inside the Xcode.app and there you will find all the /Developer Framework Lib stuff, you need to link it from there to /Developer to make everything work (i got that yesterday) and Introjucer built fine after that. I don’t know if there are any special steps that make all this automagicly, this is what i did yesterday on my new Lion in VM Workstation 8 and the latest downloaded XCode from the web.

And like someone above said i also downloaded the command line tools in the weird iTunes line interface.

Could someone write a simple guide on how to change that toolbar so that it has a build button, and how to get the Release build to appear as a normal app in a specified place, do i need some post build script to copy the result, otherwise it builds the app with some weird names, i really can’t get around that new Xcode program.


#8

Installing / updating the “Preferences > Downloads > Command Line” Tools worked for me


#9

Had the same error, downloading the Command Line Tools solved my issue as well.