Can`t get juce to build vst plugin! ONLY AFTER UPDATE

projucer

#1

I’m on windows currently. I just created a new (untouched) project and when I build it I only get the standalone version.

On Linux I did’t have any problems with this, however I used juce 5.3. Now I upgraded on windows to 5.4 and it just won’t build the vst (no compilation errors no nothing). I linked the VST3_SDK folder and left the VST Legacy thing blank.

When the standalone version is running it outputs this in Visual Studio:

'OSO.exe' (Win32): Loaded 'C:\Users\Teo\Documents\AudioProgramming\OSO\Builds\VisualStudio2017\x64\Release\Standalone Plugin\OSO.exe'. Module was built without symbols. 'OSO.exe' (Win32): Loaded 'C:\Windows\System32\ntdll.dll'. Cannot find or open the PDB file. 'OSO.exe' (Win32): Loaded 'C:\Windows\System32\kernel32.dll'. Cannot find or open the PDB file. 'OSO.exe' (Win32): Loaded 'C:\Windows\System32\KernelBase.dll'. Cannot find or open the PDB file. 'OSO.exe' (Win32): Loaded 'C:\Windows\System32\user32.dll'. Cannot find or open the PDB file. 'OSO.exe' (Win32): Loaded 'C:\Windows\System32\win32u.dll'. Cannot find or open the PDB file. 'OSO.exe' (Win32): Loaded 'C:\Windows\System32\gdi32.dll'. Cannot find or open the PDB file. 'OSO.exe' (Win32): Loaded 'C:\Windows\System32\gdi32full.dll'. Cannot find or open the PDB file.
+(Other similar things)

How can i make juce build vsts? This thing is bugging me for days.

EDIT:I unchecked from Projucer -> Settings the standalone and au version leaving only vst3 checked. When i build i get this
Severity Code Description Project File Line Suppression State Error C1083 Cannot open include file: 'pluginterfaces/vst2.x/vstfxstore.h': No such file or directory OSO_VST3 c:\users\tpc\documents\audioprogramming\oso\jucelibrarycode\modules\juce_audio_plugin_client\vst3\juce_vst3_wrapper.cpp 55

I manually looked for vstfxstore.h and couldn’t find it. I downloaded the SDK from this page https://www.steinberg.net/en/company/developers.html as i normally do.


#2

vstfxstore.h is part of the VST2 SDK which is no longer available from Steinberg. Unfortunately JUCE assumes by default you have that available even when doing VST3 plugins. You should be able to use the preprocessor definition JUCE_VST3_CAN_REPLACE_VST2=0 to disable that.


#3

I went into Projucer -> Modules -> juce_audio_plugin_client. Here you have the option to disable JUCE_VST3_CAN_REPLACE_VST2. This solved the problem. Now it is capable of building the vst :slight_smile:
There is still a problem though. As soon as i check the standalone version from build options in projucer, Visual Studio completely forgets about vst3 :expressionless:


#4

Did you update the Projucer to the latest version too when updating JUCE? I think there was some bug in the multioption chooser component in JUCE that made it uncheck previously selected options when clicking in it in a certain order.