How to get Projucer/VS to build a VST? (resolved)


#1

I have been using Projucer with Visual Studio 2017 for the past few months building projects. Up to now, I have just been building standalone exes as it was easiest for testing (it would just open the standalone application automatically after building so I could immediately test).

Now I am ready to build some VSTs so I can test them in audio projects. These are for Synthesisers.

I tried selecting VST3 or VST legacy in the Projucer profile and building in Visual Studio, but I get these errors:

Error C1083 Cannot open include file: ‘pluginterfaces/vst2.x/aeffect.h’: No such file or directory DrumSynth_VST c:\juce\modules\juce_audio_plugin_client\vst\juce_vst_wrapper.cpp 95
OR:
Severity Code Description Project File Line Suppression State
Error C1083 Cannot open include file: ‘pluginterfaces/vst/vsttypes.h’: No such file or directory DrumSynth_VST3 c:\juce\modules\juce_audio_processors\format_types\juce_vst3headers.h 98

And no VST is made.

What am I doing wrong? Any suggestions?


#2

Please refer to that Thread:

TL;DR: for VST3 you don’t need to add anything, keep all SDK paths empty and for VST Legacy, if you don’t have the old SDK and a countersigned license agreement from Steinberg (no longer available), you cannot build and distribute old VSTs


#3

Thanks Daniel. That seems to address why VST legacy wouldn’t work.

But when I try to do just VST3 I’m getting an error as well as listed:

Error C1083 Cannot open include file: ‘pluginterfaces/vst/vsttypes.h’: No such file or directory DrumSynth_VST3 c:\juce\modules\juce_audio_processors\format_types\juce_vst3headers.h 98

I looked in my Projucer settings and this is what it displays under VST3:

However, I have no directory “c:\SDKs”.

Is this perhaps indicative of the problem?


#4

Yes, it uses the path from the global settings (that’s what the grey colour indicates). Open the preferences and get rid of that path.

Hope that helps


#5

Projucer has the option “JUCE_VST3_CAN_REPLACE_VST2” enabled by default for the juce_audio_plugin_client module. That option requires the problematic VST2 header files to be present.


#6

Hi Xenakios,

How do I change that? I don’t see it anywhere in the Projucer. I tried opening my jucer file to view the XML and there’s nothing in it to that effect either.


#7


#8

Sorry @daniel, but I don’t understand. You say “get rid of that path”. But what am I supposed to put there? I don’t have any “SDK” folder anywhere. What is supposed to be there to build a VST3? Do I need to download something extra?

Also thanks @Xenakios, I have never edited things in there before so didn’t realize that’s where it was. Unfortunately though that didn’t fix the problem and it still gives the same error:

Error C1083 Cannot open include file: ‘pluginterfaces/vst/vsttypes.h’: No such file or directory DrumSynth_VST3 c:\juce\modules\juce_audio_processors\format_types\juce_vst3headers.h 98

Edit: Found the folder:
C:\JUCE\modules\juce_audio_processors\format_types\VST3_SDK

I’ll try that…

Edit2: That worked. Thanks.


#9

Did you manage to find this dialog, where the global defaults are stored?

I assume, there you find the C:\SDKs\VST3_SDK, that I suggested to get rid of. The presence of either this one or of the one in the project will disable the built in, that’s when it fails.