VST2/VST3 unable to find headers, it was working, then something happened


#1

I’m very new to JUCE and haven’t really done much with Visual C++, although, I’ve been using it off and on for odd projects for years. I’ll try to be as brief as possible.

I was working on some demo code that I was able to successfully compile multiple times to a VST. This was using 3.69 of the VST SDK. At some point I upgraded from JUCE 5.3.2 to 5.4.1, the plugin was still able to compile. Recently I switched to doing some work in the look and feel demo trying to learn some things about look and feel. I then switched back to working on the VST and now Visual Studio (2017 community) is complaining that it can’t find files from the VST SDK.

I am using projucer to generate the solution and load the IDE from within projucer.

I tried just building the noisegate demo plugin and the same problem. My VST sdks are setup in the global settings and I’ve tried both of the VST SDK versions that I have on my hard drive. The 3.69 which has VST2 and VST3, and 3.5.2 VST3 (from 2012) and the vst2.x from about the same time. I set the path(s) to the directory that is the parent of “pluginterfaces…”

When I look at the project settings in Visual C++ the VST SDK is on the include search path. However, if I right click the include file that it can’t load, Visual C++ complains that it can’t find that file on the path. This is true for both VST2 and VST3, albeit, with different files. I can be more specific here if necessary, but I’m hoping that I’ve just changed something very obvious in projucer.

Visual Studio has been updated to the latest, Windows 10 also has all of its updates.

What’s frustrating about this is that I don’t really have a good way to debug this build process so my testing is a bunch of stabbing in the dark. Any thoughts on what to check for would be appreciated.


#2

Related to https://forum.juce.com/t/steinberg-closing-down-vst2-for-good/


#3

The removal of JUCE’s embedded VST2 SDK contains more useful information.


#4

Thanks for responding guys. If I understand you correctly, that’s not it. I’m using Steinberg’s SDK. This is some sort of configuration issue that I can’t seem to figure out. It was compiling fine with Steinberg’s SDK, and now it’s not.

I’m doing more testing today. I’ll report what I find here in case anyone else runs into the same issue, but, I was hoping that I’m overlooking something simple in terms of configuration settings.