Can’t get rid of Audio Inputs in VST2 plugin (FIXED)

I want a plugin that has no audio inputs, and only audio outputs. It’s an instrument. It should have a Midi Input and Midi Output. The Projucer flags are set like:

[x] Plugin is a Synth
[x] Plugin MIDI Input
[x] Plugin MIDI Output
[ ] Midi Effect Plugin

In the AudioProcessor Constructor, I have the following (only an output bus declared):

PluginProcessor::PluginProcessor()
		: AudioProcessor (BusesProperties().withOutput("Output", AudioChannelSet::stereo(), true)),
[etc….]

In AudioPluginHost (on a Mac), the VST3 has no audio inputs (correct). The AU has no audio inputs (correct). But the VST2 still has audio inputs. How the heck do I get rid of them?


I also tried:

: AudioProcessor (BusesProperties().withInput("Input", AudioChannelSet::disabled(), true)),
: AudioProcessor (BusesProperties().withOutput("Output", AudioChannelSet::stereo(), true)),

… but that just hits an assert.

I can load other third party VST2s that do not have audio inputs. So there must be a way to do it….thanks!

I fixed it, for anyone interested. Back when I first created this project, I was attempting to have it be a MidiEffect - no longer. However, in my code for the AudioProcessor-derived class, I still had this leftover:

    bool isMidiEffect() const override  { return true; }

…and in the juce_VST_Wrapper.cpp file, is this:

       if (processor->isMidiEffect())
            maxNumInChannels = maxNumOutChannels = 2;

So, only for the VST2 plugin version, it was forcing it to have 2 input channels.