Can't attach to Ableton on mac OS

trying to debug (attach me IDE to) a plugin in ableton on mac OS and I get this error:

attach failed (Not allowed to attach to process. Look in the console messages (, near the debugserver entries, when the attach failed. The subsystem that denied the attach permission will likely have logged an informative message about why it was denied.)
anyone had this before?

Using Clion

I ran:

codesign --display --xml --entitlements daw.entitlements /Applications/Ableton\ Live\ 11\
codesign -s - --deep --force --options=runtime --entitlements daw.entitlements /Applications/Ableton\ Live\ 11\`

(I edited the xml according to some post i found
– added: <key></key><true/>

when I ran it, I got:

/Applications/Ableton Live 11 replacing existing signature
/Applications/Ableton Live 11 resource fork, Finder information, or similar detritus not allowed

not sure if thats expected

I was trying to attach to the “Ableton index” executable, rather than “Live”

1 Like

i have the same issue but i dont understand what you mean with your answer.
Could you tell me how to fix that issue?



Had this problem in the past. I think disabling SIP on your machine fixed the issue for me: Disabling and Enabling System Integrity Protection | Apple Developer Documentation

Hope this helps.

1 Like

Unlike latest macOS with AUHosting where you must disable SIP…
Thank god, some hosts still allows you to resign them without compromising your device…


thanks it worked

1 Like