Problems debuggin auval

Hi, just come to debug an auval problem, first time in a while and am getting this when trying to run from XCode:

Anyone any ideas? thx

auval is just a script that calls auvaltool, try launching auvaltool instead. Although it’s been years since I’ve had to do much plugin development so I might be wrong.

thx - i’d already tried that - no joy

it’s strange that the path listed in the error points inside your home directory.
Perhaps it’s happening also for auvaltool, while you should refer to the system-wide “/usr/bin/auvaltool” instead?

I’ve tried all combinations of running it from where it is, copying it elsewhere (used to work) - can’t seem to run it any way at all.

1 Like

what does it say at the Terminal if you:

lipo -info auval


file auval


Especially the latter should list the architectures present if it’s an executable, or it should inform you if it’s just a script, in which case you can examine it with a text editor to see what it does call and repeat the commands on that executable

I noticed the same thing. In Big Sur I get the message: Message from debugger: attach failed (Not allowed to attach to process. Look in the console messages (, near the debugserver entries when the attached failed. The subsystem that denied the attach permission will likely have logged an informative message about why it was denied.)

I’ve tried a variety of things (late attachment as well as launching directly from /usr/bin/auvaltool) to no avail. Makes debugging any sort of validation issues a massive pain. I have production plugins that validate without issue in every OSX rev, except for Big Sur. I’ve managed to track down the rough location of the problem, but I need to be able to step through it.

Via error: MachProcess::AttachForDebug failed to start exception thread: unable to start the exception thread

Perhaps in this case the issue is similar to what was already happening for Ableton Live and one needs to re-sign auval with tweaked entitlements in order to allow debugging?

See: Debugging Ableton Live

Wow, that is beyond ridiculous. :joy: Apple wants me to notarize and/or sign a binary I didn’t compile?

Things are getting out of hand.

(By the way, no trouble on Mojave or any of our other build servers)


This script did the trick:

However I can no longer run my copy of auvaltool in the shell - it gets termed. Which wouldn’t normally be an issue, except for the fact that debugging with this resigned copy of auval, when launched in the debugger, successfully validates the plugin. Points to a possible race, but I cannot execute my copy outside of a debugger ctx to know for sure.

gilgm@macmini-bigsur ~ % ./auvaltool
zsh: killed ./auvaltool