Can't directly connect audio in to out in Plug-in host


#1

I downloaded today’s svn tip and tried the lastest version of the plug-in host project. With the Novation ASIO drivers I tried connecting the Audio Input node to the Audio Output. A humming noise ensured and the audio was distorted. Everything worked if I introduced another node (like a delay) in the path.

I’ve heard that if you introduce a feedback loop in a digital audio path you need at least one sample delay. However, there is no internal feedback loop in the audio device. Is this a bug or how it’s supposed to work? Please explain.


#2

I think this is probably a bug - the plugin host code on the tip is work-in-progress at the moment.


#3

I also tried this with the ASIO4ALL driver. The results are the same: a loud hum with noise and extreme audio distortion.


#4

Have you tried the latest tip version? It was working last time I used it.


#5

I finally got a chance to try it with version 539, the latest version as of 9/28/08 and I can finally connect audio in and out freely with no problems. Thanks for fixing this, sorry it took so long to get back to testing this.