Can't even get HelloWorld application to launch


#1

Hello fellow Jucers,

I’m a total noob here… I’m a professional web dev/music & audio enthusiast who thought he’d give developing a few VST plugins a shot. Seems like a lot of fun…

Unfortunately after an entire day of fiddling, I can’t seem to get even the “HelloWorld” example project to launch on my machine. (Windows 7.) … It’s quite frustrating!

The build seems to be successful in projucer, but upon attempted “Launch Application” I receive the following error:

“The program can’t start because api-ms-win-core-winrt-string-l1-1-0.dll is missing from your computer. Try reinstalling the program to fix this problem.”

Naturally I searched the error on google, and it seems that is part of Visual C++ Redistributable for Visual Studio 2015…

I’m using Visual Studio Community 15… and when I try to download/reinstall from here https://www.microsoft.com/en-us/download/details.aspx?id=48145 it tells me I’ve already got it installed. ;(

ANY help would be greatly appreciated. I’m wanting to dive in and try to play with / reverse engineer some of the examples! But this is seriously holding me up!.

Thanks in advance.
Alex


#2

Can you get a basic non-JUCE Visual C++ program to compile and run at all?

Have you actually got the api*dll file?


#3

I was just able to create a basic windows 32 desktop application project, using Visual C++, and it compiles and runs no problem.

Can you be more clear on the api*dll? How would I verify whether or not I have it? Thanks.


#4

Did you try a clean install of VS 2015? (i.e. Just remove everything and download + install)


#5

I’m working on doing this now… The community edition of Visual Studio 2015 should be fine, ya?

Thanks so much guys, I’ll report back after reinstall.


#6

No luck… I tried uninstalling and reinstalling Visual Studio, the .NET framework, the win developers SDK, to no avail…

Even tried seeing if my windows user was corrupt as I read that maybe a possibility… but nothing. Ugh.


#7

hi modfreq,
I’m just as new to this as you are (installed Juce yesterday), but got the hello world app to run. It worked out of the box for me (fresh install) on WIN10…
I found the api-ms-win-core-winrt-string-l1-1-0.dll in C:\Windows.old\Windows\SysWOW64, and in C:\Windows.old\Windows\System32; so in the Windows.old folder.
This .dll file is a leftover from a Windows8 install back in 2012. It’s possible that Windows7 needs this .dll file, while it may not be available anymore in Visual Studio 2015.
ProJucer refers to Visual Studio 2013 in its \extras\Projucer\Builds folder, and to Visual Studio 2010 in its \extras\binarybuilder\Builds folder, among others. So maybe you need an older version of Visual Studio for Projucer to work.
Logic dictates that newer versions of Visual Studio should be backward compatible, but I’m not sure if Microsoft extends this support as far back as Win7 for its development API.
Hope you get it to work for you :slight_smile:
Peter


#8

I really appreciate the help!

Unfortunately I just tried an install of VC 2013, to no avail either. =\ … hmm… I’m itching to get my hands dirty! thinks


#9

Very odd that it wouldn’t have installed correctly, but maybe it’s just time to upgrade to something newer than Windows 7!


#10

Ah the old ‘why don’t you upgrade your computer’ move… :slight_smile:


#11

http://www.credland.net/tmp/ - copy of the 32-bit version of the DLL to try if all else fails.

You might want to see if you can uninstall the C++ redist package and reinstall tho?


#12

Juce offers it’s latest version only for download,
but at sourceforge https://sourceforge.net/p/juce/code/ref/master/tags/
you can find older versions of Juce, that depend on older versions of visual studio,
and should therefore work with older windows versions. Maybe there’s a working version
in there for you.


#13

GitHub too;)


#14

Thanks all for the thoughtful replies.

I’ve been busy with work, and haven’t had too much time to troubleshoot, but this is really bugging me.

I uninstalled/reinstalled all instances of Visual C++ as someone suggested, but still get the same exact error.

I guess I’ll have to try a previous version sometime this weekend (Seems counter-intuitive, but whatever) … Hopefully I don’t have to bail on Juce all together, looks promising.


#15

This doesn’t feel like a JUCE problem to me…did you check your computer to see if you actually have this DLL?